Skip to content

← Actionable
Medium, CVSS 6.1amended

SVGO: removeScripts incompletely sanitizes executable HTML in SVG foreignObject elements

CVE-2026-84369GHSA-4vpr-x523-8j87

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (svgo 4.1.0, 3.3.5, 2.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm svgo

    Affected
    >= 1.0.0, < 2.8.4>= 3.0.0, < 3.3.5>= 4.0.0, < 4.1.0
    Fixed in
    2.8.4, 3.3.5, 4.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-84369: 0.43% estimated exploitation activity in the next 30 days; percentile 37.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SVGO's opt-in removeScripts plugin did not inspect executable HTML content inside SVG <foreignObject elements. Applications that used this plugin as their only protection for untrusted SVG input could produce SVGs containing active HTML and expose users to cross-site scripting (XSS). SVGO is an optimizer rather than a comprehensive sanitization library, but removeScripts is maintained for consumers that already rely on it to remove common script execution paths. Details Although the plugin removed SVG and XHTML <script elements, it left other HTML execution paths inside <foreignObject unchanged. These included: - event-handler attributes such as onload and onbeforetoggle; - srcdoc documents, including on <iframe elements; - executable URLs in HTML attributes such as action, data, formaction, href, and src. An attacker could place one of these payloads in an SVG. If an application optimized the untrusted SVG with removeScripts and then served the result in an active browser…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4vpr-x523-8j87

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4vpr-x523-8j87

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4vpr-x523-8j87

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84369

Advisory: SVGO: removeScripts incompletely sanitizes executable HTML in SVG foreignObject elements
IDs: CVE-2026-84369, GHSA-4vpr-x523-8j87
Record: https://patchnext.com/advisories/cve-2026-84369 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: svgo 4.1.0, 3.3.5, 2.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm svgo: affected >= 1.0.0, < 2.8.4; >= 3.0.0, < 3.3.5; >= 4.0.0, < 4.1.0; fixed in 2.8.4, 3.3.5, 4.1.0

## Suggested inspection (read-only)
- `npm ls svgo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on svgo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4vpr-x523-8j87 (GitHub-reviewed advisory GHSA-4vpr-x523-8j87 lists affected ranges: npm svgo >=1.0.0 =3.0.0 =4.0.0 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-4vpr-x523-8j87 (OSV record GHSA-4vpr-x523-8j87 lists affected ranges: npm svgo >=1.0.0 =3.0.0 =4.0.0 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…