Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
CVE-2026-84360GHSA-vc32-4gwf-77xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/0xJacky/Nginx-UI
- Affected
- < 1.9.10-0.20260703131214-23d1934099b0
- Fixed in
- 1.9.10-0.20260703131214-23d1934099b0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6799 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vc32-4gwf-77xp lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc32-4gwf-77xp lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-84360: 0.42% estimated exploitation activity in the next 30 days; percentile 36.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An OTP-enabled authenticated user who cannot use the HTTP configuration mutation endpoints without a valid secure session can still mutate Nginx configuration through /mcp and /mcpmessage using only ordinary authentication. Details The HTTP configuration mutation surface is explicitly grouped behind middleware.RequireSecureSession(). By contrast, the MCP endpoints are exposed with only middleware.AuthRequired(). The MCP server exposes configuration mutation tools including nginxconfigadd and nginxconfigmodify, so OTP-enabled users gain an alternate path around the intended step-up requirement. Relevant code paths: - api/config/router.go - internal/middleware/securesession.go - mcp/router.go - mcp/config/configadd.go - mcp/config/configmodify.go This is a security-control bypass rather than a missing feature. The product already established that OTP-enabled users should complete a secure session before high-impact configuration mutations are accepted on the HTTP path. PoC I…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vc32-4gwf-77xp
- Revision 2 · amended ·
Amended from osv record GO-2026-6799
- Revision 1 · created ·
Published from osv record GHSA-vc32-4gwf-77xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84360 Advisory: Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools IDs: CVE-2026-84360, GHSA-vc32-4gwf-77xp Record: https://patchnext.com/advisories/cve-2026-84360 (revision 3, source checked 26 Oct 2026, 15:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/0xJacky/Nginx-UI: affected < 1.9.10-0.20260703131214-23d1934099b0; fixed in 1.9.10-0.20260703131214-23d1934099b0 ## Suggested inspection (read-only) - Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/0xJacky/Nginx-UI. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6799 (OSV record GO-2026-6799 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-vc32-4gwf-77xp (OSV record GHSA-vc32-4gwf-77xp lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)) - Verified: https://github.com/advisories/GHSA-vc32-4gwf-77xp (GitHub-reviewed advisory GHSA-vc32-4gwf-77xp lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0) Commands are suggestions: review each one before running it.
Loading voting…