Skip to content

← Actionable
High, CVSS 8.3amended

Nginx UI: MCP configuration tools bypass restricted directive validation and allow secondary authenticated users to execute NJS in Nginx worker context

CVE-2026-84319GHSA-5r62-gj48-897x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
EPSS
  • CVE-2026-84319: 0.28% estimated exploitation activity in the next 30 days; percentile 20.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The regular HTTP configuration API rejects restricted Nginx directives such as loadmodule, jsimport, and jscontent. However, the MCP configuration interface allows a secondary authenticated user to write and apply equivalent restricted configuration content. In the lab, this allowed the user to load ngxhttpjsmodule.so, import attacker-controlled JavaScript, reload Nginx, and execute NJS in the Nginx worker context. This is authenticated and is not OS command execution by itself. Affected component - /mcp - /mcpmessage - MCP tool: nginxconfigadd - Nginx configuration validation Impact A secondary authenticated user can bypass the restricted directive validation enforced by the HTTP API and execute attacker-controlled NJS inside the Nginx worker context. This may allow modification of Nginx runtime behavior, including responses, routing, headers, redirects, and request handling. Minimal PoC Preconditions - Attacker has a secondary authenticated Nginx UI account. - MCP is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5r62-gj48-897x

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6774

  3. Revision 1 · created ·

    Published from osv record GHSA-5r62-gj48-897x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84319

Advisory: Nginx UI: MCP configuration tools bypass restricted directive validation and allow secondary authenticated users to execute NJS in Nginx worker context
IDs: CVE-2026-84319, GHSA-5r62-gj48-897x
Record: https://patchnext.com/advisories/cve-2026-84319 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/Nginx-UI: affected < 1.9.10-0.20260703131214-23d1934099b0; fixed in 1.9.10-0.20260703131214-23d1934099b0

## Suggested inspection (read-only)
- Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/Nginx-UI.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5r62-gj48-897x (OSV record GHSA-5r62-gj48-897x lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6774 (OSV record GO-2026-6774 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed))
- Verified: https://github.com/advisories/GHSA-5r62-gj48-897x (GitHub-reviewed advisory GHSA-5r62-gj48-897x lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0)

Commands are suggestions: review each one before running it.

Loading voting…