Skip to content

← Actionable
High, CVSS 8.8amended

Nginx UI: MCP nginx_config_add Bypasses Directive Validation — Authenticated RCE

CVE-2026-84318GHSA-9jww-cxg5-rj9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/0xJacky/Nginx-UI

    Affected
    >= 1.9.10-0.20250506154222-1330888280a2, < 1.9.10-0.20260703131214-23d1934099b0
    Fixed in
    1.9.10-0.20260703131214-23d1934099b0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-84318: 0.82% estimated exploitation activity in the next 30 days; percentile 57.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The MCP tool nginxconfigadd writes nginx configuration files to disk and triggers an nginx reload without calling config.ValidateConfigFile. The identical flow in the REST API (POST /api/configs) does call that function and correctly rejects dangerous directives. An authenticated attacker can exploit this gap to write config files containing any blocked directive (perl, jsimport, loadmodule, user root, etc.), bypassing nginx-ui's entire security layer. On a server with the nginx Perl, njs, or Lua module loaded, this is post-authentication Remote Code Execution. Details api/config/add.go (line 46) calls config.ValidateConfigFile before writing: mcp/config/configadd.go (line 79) omits that call entirely and writes directly: config.ValidateConfigFile runs two checks: - ValidateConfigContent — rejects control characters, enforces encoding. - ValidateConfigDirectives — rejects a blocklist of dangerous directives: perl, perlmodules, perlrequire, perlset, jsimport, jsset, jscontent,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9jww-cxg5-rj9m

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6781

  3. Revision 1 · created ·

    Published from osv record GHSA-9jww-cxg5-rj9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84318

Advisory: Nginx UI: MCP `nginx_config_add` Bypasses Directive Validation — Authenticated RCE
IDs: CVE-2026-84318, GHSA-9jww-cxg5-rj9m
Record: https://patchnext.com/advisories/cve-2026-84318 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/Nginx-UI: affected >= 1.9.10-0.20250506154222-1330888280a2, < 1.9.10-0.20260703131214-23d1934099b0; fixed in 1.9.10-0.20260703131214-23d1934099b0

## Suggested inspection (read-only)
- Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/Nginx-UI.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6781 (OSV record GO-2026-6781 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20250506154222-1330888280a2 <1.9.10-0.20260703131214-23d1934099b0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-9jww-cxg5-rj9m (OSV record GHSA-9jww-cxg5-rj9m lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20250506154222-1330888280a2 <1.9.10-0.20260703131214-23d1934099b0 (fixed))
- Verified: https://github.com/advisories/GHSA-9jww-cxg5-rj9m (GitHub-reviewed advisory GHSA-9jww-cxg5-rj9m lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20250506154222-1330888280a2 <1.9.10-0.20260703131214-23d1934099b0)

Commands are suggestions: review each one before running it.

Loading voting…