Nginx UI: Account Takeover via Missing RequireSecureSession on User Management Endpoint
CVE-2026-84314GHSA-2gc7-j998-5xx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/0xJacky/Nginx-UI
- Affected
- < 1.9.10-0.20260703131214-23d1934099b0
- Fixed in
- 1.9.10-0.20260703131214-23d1934099b0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2gc7-j998-5xx6 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6771 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2gc7-j998-5xx6 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-84314: 0.42% estimated exploitation activity in the next 30 days; percentile 36.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary POST /api/users/:id allows any authenticated user to change any other user's password without RequireSecureSession (2FA verification). In contrast, the self password change endpoint POST /api/user/password correctly requires RequireSecureSession. This inconsistency enables any authenticated user to take over the initial admin account (user ID 1) by simply changing its password. Details nginx-ui enforces RequireSecureSession middleware on sensitive operations such as self password change (api/user/router.go:55), self profile update (api/user/router.go:54), settings modification (api/settings/router.go:12), and config file deletion/rename (api/config/router.go:16-21). However, the user management endpoint registered in InitManageUserRouter (api/user/user.go:31-68) is mounted on the g router group (router/routers.go:92) which only applies middleware.AuthRequired() and middleware.Proxy() — no RequireSecureSession(). As a result, POST /api/users/:id with a password field in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-2gc7-j998-5xx6
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6771
- Revision 1 · created ·
Published from osv record GHSA-2gc7-j998-5xx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84314 Advisory: Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint IDs: CVE-2026-84314, GHSA-2gc7-j998-5xx6 Record: https://patchnext.com/advisories/cve-2026-84314 (revision 4, source checked 26 Oct 2026, 15:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/0xJacky/Nginx-UI: affected < 1.9.10-0.20260703131214-23d1934099b0; fixed in 1.9.10-0.20260703131214-23d1934099b0 ## Suggested inspection (read-only) - Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/0xJacky/Nginx-UI. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2gc7-j998-5xx6 (OSV record GHSA-2gc7-j998-5xx6 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6771 (OSV record GO-2026-6771 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)) - Verified: https://github.com/advisories/GHSA-2gc7-j998-5xx6 (GitHub-reviewed advisory GHSA-2gc7-j998-5xx6 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0) Commands are suggestions: review each one before running it.
Loading voting…