Nginx UI: TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover
CVE-2026-84313GHSA-gfrc-g87h-7h5w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/0xJacky/Nginx-UI
- Affected
- < 1.9.10-0.20260703131214-23d1934099b0
- Fixed in
- 1.9.10-0.20260703131214-23d1934099b0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6786 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfrc-g87h-7h5w lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gfrc-g87h-7h5w lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-84313: 0.54% estimated exploitation activity in the next 30 days; percentile 45.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Endpoints that bind a TOTP secret (`POST /api/otp_enroll`) or register a WebAuthn passkey (`POST /api/finish_passkey_register`) for the *current* user require only a valid JWT. There is no current-password re-prompt and the routes are explicitly registered outside the `RequireSecureSession()` group. With only a stolen JWT, an attacker can attach their own second factor to the victim's account, surviving any subsequent password rotation and locking the legitimate user out.
Details `api/user/router.go:34-39` — note the routes registered *before* the secure-session group: ```go r.GET("/otp_secret", GenerateTOTP) r.POST("/otp_enroll", EnrollTOTP) // ← outside RequireSecureSession r.GET("/begin_passkey_register", BeginPasskeyRegistration) r.POST("/finish_passkey_register", FinishPasskeyRegistration) // ← outside RequireSecureSession o := r.Group("", middleware.RequireSecureSession()) { o.GET("/otp_reset", ResetOTP) // reset *is* protected — inconsistent ... } ```…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-gfrc-g87h-7h5w
- Revision 2 · amended ·
Amended from ghsa record GHSA-gfrc-g87h-7h5w
- Revision 1 · created ·
Published from osv record GO-2026-6786
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84313 Advisory: Nginx UI: TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover IDs: CVE-2026-84313, GHSA-gfrc-g87h-7h5w Record: https://patchnext.com/advisories/cve-2026-84313 (revision 3, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/0xJacky/Nginx-UI: affected < 1.9.10-0.20260703131214-23d1934099b0; fixed in 1.9.10-0.20260703131214-23d1934099b0 ## Suggested inspection (read-only) - Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/0xJacky/Nginx-UI. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6786 (OSV record GO-2026-6786 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0) - Verified: https://github.com/advisories/GHSA-gfrc-g87h-7h5w (GitHub-reviewed advisory GHSA-gfrc-g87h-7h5w lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0) - Verified: https://osv.dev/vulnerability/GHSA-gfrc-g87h-7h5w (OSV record GHSA-gfrc-g87h-7h5w lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260703131214-23d1934099b0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…