Skip to content

← Actionable
Medium, CVSS 6.5amended

Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used

CVE-2026-84306GHSA-r3j6-gpjw-qfjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/filament 5.7.6, 4.12.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist filament/filament

    Affected
    >= 4.0.0, < 4.12.6>= 5.0.0, < 5.7.6
    Fixed in
    4.12.6, 5.7.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-84306: 0.45% estimated exploitation activity in the next 30 days; percentile 39.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw in the handling of one-time codes for app-based multi-factor authentication allows a previously issued code to be used after a newer code has already been accepted. This issue does not affect email-based MFA. Submitting the exact same code twice was already prevented, but any other code within the accepted time window was not. If an attacker gains access to both the user's password and a single one-time code, that code stays usable for the remainder of its time window, which is around four minutes on the default settings, including after the legitimate user has already logged in with a newer code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r3j6-gpjw-qfjr

  2. Revision 1 · created ·

    Published from osv record GHSA-r3j6-gpjw-qfjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84306

Advisory: Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used
IDs: CVE-2026-84306, GHSA-r3j6-gpjw-qfjr
Record: https://patchnext.com/advisories/cve-2026-84306 (revision 2, source checked 26 Oct 2026, 14:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: filament/filament 5.7.6, 4.12.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist filament/filament: affected >= 4.0.0, < 4.12.6; >= 5.0.0, < 5.7.6; fixed in 4.12.6, 5.7.6

## Suggested inspection (read-only)
- Packagist filament/filament: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on filament/filament.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r3j6-gpjw-qfjr (OSV record GHSA-r3j6-gpjw-qfjr lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.7.6 (fixed))
- Verified: https://github.com/advisories/GHSA-r3j6-gpjw-qfjr (GitHub-reviewed advisory GHSA-r3j6-gpjw-qfjr lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.7.6)

Commands are suggestions: review each one before running it.

Loading voting…