Skip to content

← Actionable
High, CVSS 7.5amended

fast-uri vulnerable to authority injection via an unvalidated port in serialize

CVE-2026-84292GHSA-qw65-cvwx-89v3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.4, 3.1.7, 2.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    < 2.4.6>= 3.0.0, < 3.1.7>= 4.0.0, < 4.1.4
    Fixed in
    3.1.7, 4.1.4, 2.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-84292: 0.24% estimated exploitation activity in the next 30 days; percentile 15.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri serializes the port component of a URI without validating it. When recomposing the authority, fast-uri escapes the userinfo and host components but concatenates the port verbatim, so a port value that is not a sequence of digits can inject authority delimiters. For example, serializing a component whose port is @127.0.0.1:8124 produces http://trusted.example:@127.0.0.1:8124/app, demoting the intended host to userinfo and pointing the authority at an attacker-controlled host. Both fast-uri and Node's URL read the result back as the attacker's host with no error, so re-validating the built URI does not catch it. This affects applications that build URIs from parts and assign untrusted data to the port component (for example a fixed host from configuration and a port taken from user input or a service record). The same path is reachable through serialize(), normalize(), and equal() in their object forms. A port obtained from parse() is always digits and is not affected.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qw65-cvwx-89v3

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qw65-cvwx-89v3

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qw65-cvwx-89v3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84292

Advisory: fast-uri vulnerable to authority injection via an unvalidated port in serialize
IDs: CVE-2026-84292, GHSA-qw65-cvwx-89v3
Record: https://patchnext.com/advisories/cve-2026-84292 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.4, 3.1.7, 2.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected < 2.4.6; >= 3.0.0, < 3.1.7; >= 4.0.0, < 4.1.4; fixed in 3.1.7, 4.1.4, 2.4.6

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qw65-cvwx-89v3 (GitHub-reviewed advisory GHSA-qw65-cvwx-89v3 lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.4)
- Verified: https://osv.dev/vulnerability/GHSA-qw65-cvwx-89v3 (OSV record GHSA-qw65-cvwx-89v3 lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…