Skip to content

← Actionable
High, CVSS 7.5

Concrete CMS contains a CSRF vulnerability

CVE-2026-8421GHSA-4c8m-6fwx-m7xq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (concrete5/concrete5 9.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-8421: 0.17% estimated exploitation activity in the next 30 days; percentile 6.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Concrete CMS 9.5.0 and below contains a CSRF vulnerability in the installpackage() method of concrete/controllers/singlepage/dashboard/extend/install.php. An attacker who can cause an authenticated administrator to visit a crafted page, and who has placed or caused a package to be present under DIRPACKAGES/<handle/, can force the installation of that package without any CSRF protection. Package installation executes the package controller's install() method as the web server user, enabling remote code execution. In order to be vulnerable, the victim must be passing canInstallPackages. The Concrete CMS security team thanks @maru1009 for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4c8m-6fwx-m7xq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8421

Advisory: Concrete CMS contains a CSRF vulnerability
IDs: CVE-2026-8421, GHSA-4c8m-6fwx-m7xq
Record: https://patchnext.com/advisories/cve-2026-8421 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: concrete5/concrete5 9.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist concrete5/concrete5: affected < 9.5.1; fixed in 9.5.1

## Suggested inspection (read-only)
- Packagist concrete5/concrete5: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on concrete5/concrete5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4c8m-6fwx-m7xq (GitHub-reviewed advisory GHSA-4c8m-6fwx-m7xq lists affected ranges: Packagist concrete5/concrete5 >=0 <9.5.1)

Commands are suggestions: review each one before running it.

Loading voting…