LibreNMS — Stored XSS via SNMP/Syslog Data in Legacy Templates
CVE-2026-84192GHSA-7w8c-qgxg-m7jx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 26.5.0
- Fixed in
- 26.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7w8c-qgxg-m7jx lists affected ranges: Packagist librenms/librenms >=0 <26.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7w8c-qgxg-m7jx lists affected ranges: Packagist librenms/librenms >=0 <26.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-84192: 0.33% estimated exploitation activity in the next 30 days; percentile 26.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple legacy PHP template files in LibreNMS directly output SNMP-sourced and syslog-sourced data into HTML without escaping. An attacker who controls a monitored network device (via compromised SNMP agent or syslog sender) can inject arbitrary JavaScript that executes when any authenticated LibreNMS user views the affected pages. Vulnerable Code Location 1: Syslog program field (clearest instance) File: includes/html/print-syslog.inc.php:11,13 The program field is output without htmlspecialchars() while the adjacent msg field IS properly escaped. The program value comes from syslog messages received from monitored devices. Location 2: Alert details ifAlias (highest impact — main alerts page) File: includes/html/functions.inc.php:607 The ifAlias (port description) comes from SNMP polling and is stored in the ports table. When a port-related alert fires, formatalertdetails() renders it unescaped. Multiple other fields in this function are also unescaped:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7w8c-qgxg-m7jx
- Revision 1 · created ·
Published from osv record GHSA-7w8c-qgxg-m7jx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84192 Advisory: LibreNMS — Stored XSS via SNMP/Syslog Data in Legacy Templates IDs: CVE-2026-84192, GHSA-7w8c-qgxg-m7jx Record: https://patchnext.com/advisories/cve-2026-84192 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 26.5.0; fixed in 26.5.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7w8c-qgxg-m7jx (OSV record GHSA-7w8c-qgxg-m7jx lists affected ranges: Packagist librenms/librenms >=0 <26.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7w8c-qgxg-m7jx (GitHub-reviewed advisory GHSA-7w8c-qgxg-m7jx lists affected ranges: Packagist librenms/librenms >=0 <26.5.0) Commands are suggestions: review each one before running it.
Loading voting…