LibreNMS Vulnerable to Remote Code Execution via AboutController
CVE-2026-84190GHSA-jf24-8g2h-2wg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 26.5.0
- Fixed in
- 26.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jf24-8g2h-2wg7 lists affected ranges: Packagist librenms/librenms >=0 <26.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf24-8g2h-2wg7 lists affected ranges: Packagist librenms/librenms >=0 <26.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-84190: 0.86% estimated exploitation activity in the next 30 days; percentile 58.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Remote Code Execution via AboutController in LibreNMS Summary A Remote Code Execution (RCE) vulnerability exists in LibreNMS 26.3.1 through the AboutController. An authenticated administrator can manipulate the snmpget configuration parameter to execute arbitrary system commands. When the /about endpoint is accessed, the application executes the configured binary path via shellexec() without proper validation. This vulnerability leads to complete server compromise, allowing attackers to establish reverse shells, exfiltrate sensitive data, and maintain persistent access. Severity: High (CVSS 7.2) Attack Vector: Network Privileges Required: High (Administrator) User Interaction: None Impact: Complete system compromise with web server privileges --- Details Vulnerable Code File: app/Http/Controllers/AboutController.php Line: 85 Root Cause The AboutController retrieves the snmpget configuration value from the database and directly concatenates it into a shellexec() call without proper…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jf24-8g2h-2wg7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jf24-8g2h-2wg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84190 Advisory: LibreNMS Vulnerable to Remote Code Execution via AboutController IDs: CVE-2026-84190, GHSA-jf24-8g2h-2wg7 Record: https://patchnext.com/advisories/cve-2026-84190 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 26.5.0; fixed in 26.5.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jf24-8g2h-2wg7 (OSV record GHSA-jf24-8g2h-2wg7 lists affected ranges: Packagist librenms/librenms >=0 <26.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jf24-8g2h-2wg7 (GitHub-reviewed advisory GHSA-jf24-8g2h-2wg7 lists affected ranges: Packagist librenms/librenms >=0 <26.5.0) Commands are suggestions: review each one before running it.
Loading voting…