LibreNMS: Stored XSS via graph_descr admin config settings echoed without escaping to all authenticated users
CVE-2026-84188GHSA-7cj5-v4pp-v632
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 26.7.0
- Fixed in
- 26.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7cj5-v4pp-v632 lists affected ranges: Packagist librenms/librenms >=0 <26.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7cj5-v4pp-v632 lists affected ranges: Packagist librenms/librenms >=0 <26.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-84188: 0.25% estimated exploitation activity in the next 30 days; percentile 16.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The graphdescr.<graphtype family of settings is echoed verbatim without htmlspecialchars() in includes/html/pages/graphs.inc.php:194. Any admin can store a malicious HTML payload that executes in every authenticated user's browser viewing that graph type. CVSS CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N — 4.8 Medium Details PoC Fix Prerequisite Admin session to set the config value.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7cj5-v4pp-v632
- Revision 1 · created ·
Published from osv record GHSA-7cj5-v4pp-v632
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-84188 Advisory: LibreNMS: Stored XSS via graph_descr admin config settings echoed without escaping to all authenticated users IDs: CVE-2026-84188, GHSA-7cj5-v4pp-v632 Record: https://patchnext.com/advisories/cve-2026-84188 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 26.7.0; fixed in 26.7.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7cj5-v4pp-v632 (OSV record GHSA-7cj5-v4pp-v632 lists affected ranges: Packagist librenms/librenms >=0 <26.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7cj5-v4pp-v632 (GitHub-reviewed advisory GHSA-7cj5-v4pp-v632 lists affected ranges: Packagist librenms/librenms >=0 <26.7.0) Commands are suggestions: review each one before running it.
Loading voting…