Skip to content

← Actionable
High, CVSS 8.7amended

xmldom: requireWellFormed element/attribute name validation is bypassable via an embedded line terminator

CVE-2026-83617GHSA-jxjr-3g7g-3944

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@xmldom/xmldom 0.9.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-83617: 0.57% estimated exploitation activity in the next 30 days; percentile 47.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An embedded line terminator bypasses the requireWellFormed serializer check for element and attribute names. The check was added to fix GHSA-w2rr-34g9-rvrj and GHSA-4w3w-2rp5-g8jm; a name whose first line is well-formed slips past it and is serialized verbatim, so the characters after the line terminator break out of the start/end tag or attribute. Callers who enabled requireWellFormed specifically to neutralize those name-injection issues remain exposed. Details xmldom builds every grammar production through a shared regexp builder that compiles with the m flag. The anchored full-string matcher used for element and attribute names, QNameexact = reg('^', QName, '$'), therefore inherits m. When it is applied as QNameexact.test(name) against an already-assembled node name, the m flag makes $ match at an interior line terminator, so the matcher accepts any value in which at least one line is a valid QName; the other lines are never constrained. A payload whose first line is a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-jxjr-3g7g-3944

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-jxjr-3g7g-3944

  4. Revision 1 · created ·

    Published from ghsa record GHSA-jxjr-3g7g-3944

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-83617

Advisory: xmldom: requireWellFormed element/attribute name validation is bypassable via an embedded line terminator
IDs: CVE-2026-83617, GHSA-jxjr-3g7g-3944
Record: https://patchnext.com/advisories/cve-2026-83617 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @xmldom/xmldom 0.9.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @xmldom/xmldom: affected >= 0.9.11, <= 0.9.11; fixed in 0.9.12

## Suggested inspection (read-only)
- `npm ls @xmldom/xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @xmldom/xmldom.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jxjr-3g7g-3944 (GitHub-reviewed advisory GHSA-jxjr-3g7g-3944 lists affected ranges: npm @xmldom/xmldom >=0.9.11 <=0.9.11)
- Verified: https://osv.dev/vulnerability/GHSA-jxjr-3g7g-3944 (OSV record GHSA-jxjr-3g7g-3944 lists affected ranges: npm @xmldom/xmldom >=0.9.11 <0.9.12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…