xmldom: Processing Instruction Target Injection Bypasses requireWellFormed
CVE-2026-83616GHSA-c7q8-3ch8-vqpv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @xmldom/xmldom
- Affected
- >= 0.7.0, <= 0.8.14>= 0.9.0, <= 0.9.11
- Fixed in
- 0.9.12, 0.8.15
npm xmldom
- Affected
- <= 0.6.0
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c7q8-3ch8-vqpv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c7q8-3ch8-vqpv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-83616: 0.61% estimated exploitation activity in the next 30 days; percentile 49.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Document.createProcessingInstruction() in @xmldom/xmldom performs no validation on the target parameter. The requireWellFormed: true serializer option validates only for : in the target and a case-insensitive xml prefix, but does not check for characters. A in the target breaks the processing instruction boundary (<?...?), allowing injection of arbitrary content into the serialized XML output. Details Document.createProcessingInstruction(target, data) at lib/dom.js around line 2413 accepts any string as the target parameter and stores it on the PI node without validation. During serialization, the requireWellFormed code path (around line 3286) performs two checks on PI targets: 1. Rejects targets containing : (namespace prefix check) 2. Rejects targets matching xml case-insensitively (reserved prefix) However, it does NOT validate that the target conforms to the XML Name production, and critically does NOT check for characters. Since processing instructions are serialized as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-c7q8-3ch8-vqpv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-c7q8-3ch8-vqpv
- Revision 1 · created ·
Published from ghsa record GHSA-c7q8-3ch8-vqpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-83616 Advisory: xmldom: Processing Instruction Target Injection Bypasses requireWellFormed IDs: CVE-2026-83616, GHSA-c7q8-3ch8-vqpv Record: https://patchnext.com/advisories/cve-2026-83616 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @xmldom/xmldom 0.9.12, 0.8.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @xmldom/xmldom: affected >= 0.7.0, <= 0.8.14; >= 0.9.0, <= 0.9.11; fixed in 0.9.12, 0.8.15 - npm xmldom: affected <= 0.6.0 ## Suggested inspection (read-only) - `npm ls @xmldom/xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @xmldom/xmldom, xmldom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c7q8-3ch8-vqpv (GitHub-reviewed advisory GHSA-c7q8-3ch8-vqpv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0) - Verified: https://osv.dev/vulnerability/GHSA-c7q8-3ch8-vqpv (OSV record GHSA-c7q8-3ch8-vqpv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0) Commands are suggestions: review each one before running it.
Loading voting…