xmldom: Quadratic-time parsing via the malformed-input recovery path — parseElementStartPart re-scan and normalize() adjacent-text merge
CVE-2026-83614GHSA-93r5-fhx6-vmg9
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @xmldom/xmldom
- Affected
- >= 0.7.0, <= 0.8.14>= 0.9.0, <= 0.9.11
- Fixed in
- 0.9.12, 0.8.15
npm xmldom
- Affected
- >= 0.3.0, <= 0.6.0
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-93r5-fhx6-vmg9 lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0.3.0 <=0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-93r5-fhx6-vmg9 lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0.3.0 <=0.6.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-83614: 0.59% estimated exploitation activity in the next 30 days; percentile 48.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary xmldom's malformed-input error-recovery path has two quadratic-time (O(n²)) behaviors that a single crafted input triggers together, so a tiny, highly compressible document (tens of KB) stalls the Node.js event loop for multiple seconds. It is reachable from DOMParser.parseFromString under default options — i.e. from unauthenticated, network-delivered XML — making this an unauthenticated denial of service. One of the two behaviors, the normalize() adjacent-text merge, is additionally reachable programmatically — via a plain normalize() call on a DOM built with adjacent text nodes, independent of the parser — so its fix must live in normalize(), not only in a parser bound. Details Finding A — parseElementStartPart quadratic re-scan A < character is not a delimiter in any tag-parsing state, so parseElementStartPart scans forward character-by-character over any embedded < until it reaches the next (or end of input), then validates the accumulated slice as a tag name and throws…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-93r5-fhx6-vmg9
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-93r5-fhx6-vmg9
- Revision 1 · created ·
Published from ghsa record GHSA-93r5-fhx6-vmg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-83614 Advisory: xmldom: Quadratic-time parsing via the malformed-input recovery path — `parseElementStartPart` re-scan and `normalize()` adjacent-text merge IDs: CVE-2026-83614, GHSA-93r5-fhx6-vmg9 Record: https://patchnext.com/advisories/cve-2026-83614 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @xmldom/xmldom 0.9.12, 0.8.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @xmldom/xmldom: affected >= 0.7.0, <= 0.8.14; >= 0.9.0, <= 0.9.11; fixed in 0.9.12, 0.8.15 - npm xmldom: affected >= 0.3.0, <= 0.6.0 ## Suggested inspection (read-only) - `npm ls @xmldom/xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @xmldom/xmldom, xmldom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-93r5-fhx6-vmg9 (GitHub-reviewed advisory GHSA-93r5-fhx6-vmg9 lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0.3.0 <=0.6.0) - Verified: https://osv.dev/vulnerability/GHSA-93r5-fhx6-vmg9 (OSV record GHSA-93r5-fhx6-vmg9 lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0.3.0 <=0.6.0) Commands are suggestions: review each one before running it.
Loading voting…