xmldom: DocType name Injection Bypasses requireWellFormed
CVE-2026-83608GHSA-27p8-2357-5qqv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @xmldom/xmldom
- Affected
- >= 0.7.0, <= 0.8.14>= 0.9.0, <= 0.9.11
- Fixed in
- 0.9.12, 0.8.15
npm xmldom
- Affected
- <= 0.6.0
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27p8-2357-5qqv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27p8-2357-5qqv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-83608: 0.61% estimated exploitation activity in the next 30 days; percentile 49.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The @xmldom/xmldom serializer emits DocumentType.name verbatim into the <!DOCTYPE … declaration with no well-formedness guard. GHSA-f6ww-3ggp-fr8h (CVE-2026-41674) hardened the serializer's requireWellFormed path for a DocumentType's sibling fields — publicId, systemId, and internalSubset — but it did not add any check for name. A (or whitespace) in the name terminates the doctype declaration early, letting the remaining characters become sibling markup in the serialized output. Because requireWellFormed: true — the recommended mitigation for the prior xmldom injection CVEs — performs no validation on the DocType name, this is a bypass of that control, in the same family as the open element-name (GHSA-w2rr-34g9-rvrj) and attribute-name (GHSA-4w3w-2rp5-g8jm) name-injection advisories. Details The serializer's DOCUMENTTYPENODE case runs the requireWellFormed block only against publicId, systemId, and internalSubset, then pushes n.name directly into the buffer between the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-27p8-2357-5qqv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-27p8-2357-5qqv
- Revision 1 · created ·
Published from ghsa record GHSA-27p8-2357-5qqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-83608 Advisory: xmldom: DocType `name` Injection Bypasses requireWellFormed IDs: CVE-2026-83608, GHSA-27p8-2357-5qqv Record: https://patchnext.com/advisories/cve-2026-83608 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @xmldom/xmldom 0.9.12, 0.8.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @xmldom/xmldom: affected >= 0.7.0, <= 0.8.14; >= 0.9.0, <= 0.9.11; fixed in 0.9.12, 0.8.15 - npm xmldom: affected <= 0.6.0 ## Suggested inspection (read-only) - `npm ls @xmldom/xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @xmldom/xmldom, xmldom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27p8-2357-5qqv (GitHub-reviewed advisory GHSA-27p8-2357-5qqv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0) - Verified: https://osv.dev/vulnerability/GHSA-27p8-2357-5qqv (OSV record GHSA-27p8-2357-5qqv lists affected ranges: npm @xmldom/xmldom >=0.7.0 =0.9.0 =0 <=0.6.0) Commands are suggestions: review each one before running it.
Loading voting…