Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-Site Scripting (XSS) via SVG Schema innerHTML Injection in @pdfme/schemas

CVE-2026-82868GHSA-87v3-4cfp-cm76

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/schemas 5.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-82868: 0.26% estimated exploitation activity in the next 30 days; percentile 18.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The SVG schema plugin in @pdfme/schemas renders user-supplied SVG content using container.innerHTML = value without any sanitization, enabling arbitrary JavaScript execution in the user's browser. Details In packages/schemas/src/graphics/svg.ts, line 87, the SVG schema's ui renderer assigns raw SVG markup directly to innerHTML when in viewer mode or form mode with readOnly: true: The isValidSVG() function (lines 11-37) only validates that the string contains <svg and </svg tags and passes DOMParser well-formedness checks. It does NOT strip or block: - <script tags embedded in SVG - Event handler attributes (onload, onerror, onclick, etc.) - <foreignObject elements containing HTML with event handlers - <animate / <set elements with onbegin / onend handlers - SVG <use elements referencing malicious external resources All of these are valid SVG and pass isValidSVG(), but execute JavaScript when inserted via innerHTML. Attack Vectors 1. Malicious Template (readOnly SVG schema) An…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-87v3-4cfp-cm76

  2. Revision 1 · created ·

    Published from osv record GHSA-87v3-4cfp-cm76

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82868

Advisory: Cross-Site Scripting (XSS) via SVG Schema innerHTML Injection in @pdfme/schemas
IDs: CVE-2026-82868, GHSA-87v3-4cfp-cm76
Record: https://patchnext.com/advisories/cve-2026-82868 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @pdfme/schemas 5.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @pdfme/schemas: affected <= 5.5.8; fixed in 5.5.9

## Suggested inspection (read-only)
- `npm ls @pdfme/schemas --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @pdfme/schemas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-87v3-4cfp-cm76 (OSV record GHSA-87v3-4cfp-cm76 lists affected ranges: npm @pdfme/schemas >=0 <5.5.9 (fixed))
- Verified: https://github.com/advisories/GHSA-87v3-4cfp-cm76 (GitHub-reviewed advisory GHSA-87v3-4cfp-cm76 lists affected ranges: npm @pdfme/schemas >=0 <=5.5.8)

Commands are suggestions: review each one before running it.

Loading voting…