Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-Site Scripting (XSS) via Select Schema Option Value Injection in @pdfme/schemas

CVE-2026-82867GHSA-qq9g-96v4-m3cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/schemas 5.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-82867: 0.31% estimated exploitation activity in the next 30 days; percentile 23.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Select schema plugin in @pdfme/schemas constructs HTML from template-defined option values using unsanitized string interpolation and sets it via innerHTML, enabling arbitrary JavaScript execution. Details In packages/schemas/src/select/index.ts, lines 159-164, the Select schema's ui renderer builds <option elements by directly interpolating option values from the template into an HTML string: The option values come from schema.options, which is an array of strings defined in the template JSON. These values are interpolated directly into the HTML string without any escaping of <, , ", &, or other HTML-special characters. An option value containing " breaks out of the value attribute and allows injection of arbitrary HTML elements and event handlers. Proof of Concept Loading the following template into a pdfme Form or Designer component triggers JavaScript execution: The injected <img onerror element executes JavaScript because it is parsed as HTML when assigned to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qq9g-96v4-m3cj

  2. Revision 1 · created ·

    Published from osv record GHSA-qq9g-96v4-m3cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82867

Advisory: Cross-Site Scripting (XSS) via Select Schema Option Value Injection in @pdfme/schemas
IDs: CVE-2026-82867, GHSA-qq9g-96v4-m3cj
Record: https://patchnext.com/advisories/cve-2026-82867 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @pdfme/schemas 5.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @pdfme/schemas: affected <= 5.5.8; fixed in 5.5.9

## Suggested inspection (read-only)
- `npm ls @pdfme/schemas --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @pdfme/schemas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qq9g-96v4-m3cj (OSV record GHSA-qq9g-96v4-m3cj lists affected ranges: npm @pdfme/schemas >=0 <5.5.9 (fixed))
- Verified: https://github.com/advisories/GHSA-qq9g-96v4-m3cj (GitHub-reviewed advisory GHSA-qq9g-96v4-m3cj lists affected ranges: npm @pdfme/schemas >=0 <=5.5.8)

Commands are suggestions: review each one before running it.

Loading voting…