PDFME has SSRF via Unvalidated URL Fetch in getB64BasePdf When basePdf Is Attacker-Controlled
CVE-2026-82866GHSA-pgx6-7jcq-2qff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/common 5.5.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @pdfme/common
- Affected
- <= 5.5.9
- Fixed in
- 5.5.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgx6-7jcq-2qff lists affected ranges: npm @pdfme/common >=0 <5.5.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgx6-7jcq-2qff lists affected ranges: npm @pdfme/common >=0 <=5.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-82866: 0.35% estimated exploitation activity in the next 30 days; percentile 28.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The getB64BasePdf function in @pdfme/common fetches arbitrary URLs via fetch() without any validation when basePdf is a non-data-URI string and window is defined. An attacker who can control the basePdf field of a template (e.g., through a web application that accepts user-supplied templates) can force the server or client to make requests to arbitrary internal or external endpoints, enabling Server-Side Request Forgery (SSRF) in SSR contexts or blind request forgery in browser contexts. Details The vulnerability exists in packages/common/src/helper.ts:130-141. When getB64BasePdf receives a string that does not start with data:application/pdf;, and window is defined, it passes the string directly to fetch(): The Zod schema for basePdf in packages/common/src/schema.ts:133-135 accepts any string: The checkGenerateProps function at packages/common/src/helper.ts:279 only validates the Zod schema shape, which permits any string value. No URL allowlist, protocol restriction, or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgx6-7jcq-2qff
- Revision 1 · created ·
Published from osv record GHSA-pgx6-7jcq-2qff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82866 Advisory: PDFME has SSRF via Unvalidated URL Fetch in `getB64BasePdf` When `basePdf` Is Attacker-Controlled IDs: CVE-2026-82866, GHSA-pgx6-7jcq-2qff Record: https://patchnext.com/advisories/cve-2026-82866 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @pdfme/common 5.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @pdfme/common: affected <= 5.5.9; fixed in 5.5.10 ## Suggested inspection (read-only) - `npm ls @pdfme/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @pdfme/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgx6-7jcq-2qff (OSV record GHSA-pgx6-7jcq-2qff lists affected ranges: npm @pdfme/common >=0 <5.5.10 (fixed)) - Verified: https://github.com/advisories/GHSA-pgx6-7jcq-2qff (GitHub-reviewed advisory GHSA-pgx6-7jcq-2qff lists affected ranges: npm @pdfme/common >=0 <=5.5.9) Commands are suggestions: review each one before running it.
Loading voting…