Skip to content

← Actionable
Medium, CVSS 4.4amended

PDFME has XSS via Unsanitized i18n Label Injection into innerHTML in multiVariableText propPanel

CVE-2026-82865GHSA-xgx4-2wgv-4jhm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/schemas 5.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-82865: 0.20% estimated exploitation activity in the next 30 days; percentile 10.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The multiVariableText property panel in @pdfme/schemas constructs HTML via string concatenation and assigns it to innerHTML using unsanitized i18n label values. An attacker who can control label overrides passed through options.labels can inject arbitrary JavaScript that executes in the context of any user who opens the Designer and selects a multiVariableText field with no {variables} in its text. Details When a user selects a multiVariableText schema field that contains no {variable} placeholders, the property panel renders instructional text by concatenating i18n-translated strings directly into innerHTML. Vulnerable sink — packages/schemas/src/multiVariableText/propPanel.ts:65-71: The comment on line 64 claims "safe string concatenation" but the result is assigned to innerHTML with no HTML escaping applied to typingInstructions or sampleField. i18n lookup has no escaping — packages/ui/src/i18n.ts:903: This is a plain dictionary lookup — no HTML encoding or sanitization.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xgx4-2wgv-4jhm

  2. Revision 1 · created ·

    Published from osv record GHSA-xgx4-2wgv-4jhm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82865

Advisory: PDFME has XSS via Unsanitized i18n Label Injection into innerHTML in multiVariableText propPanel
IDs: CVE-2026-82865, GHSA-xgx4-2wgv-4jhm
Record: https://patchnext.com/advisories/cve-2026-82865 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @pdfme/schemas 5.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @pdfme/schemas: affected <= 5.5.9; fixed in 5.5.10

## Suggested inspection (read-only)
- `npm ls @pdfme/schemas --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @pdfme/schemas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xgx4-2wgv-4jhm (OSV record GHSA-xgx4-2wgv-4jhm lists affected ranges: npm @pdfme/schemas >=0 <5.5.10 (fixed))
- Verified: https://github.com/advisories/GHSA-xgx4-2wgv-4jhm (GitHub-reviewed advisory GHSA-xgx4-2wgv-4jhm lists affected ranges: npm @pdfme/schemas >=0 <=5.5.9)

Commands are suggestions: review each one before running it.

Loading voting…