Skip to content

← Actionable
Medium, CVSS 6.5amended

PDFME Affected by Decompression Bomb in FlateDecode Stream Parsing Causes Memory Exhaustion DoS

CVE-2026-82864GHSA-vrqm-gvq7-rrwh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@pdfme/pdf-lib 5.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-82864: 0.44% estimated exploitation activity in the next 30 days; percentile 37.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The DecodeStream.ensureBuffer() method in @pdfme/pdf-lib doubles its internal buffer without any upper bound on the decompressed size. A crafted PDF containing a FlateDecode stream with a high compression ratio (decompression bomb) causes unbounded memory allocation during stream decoding, leading to memory exhaustion and denial of service in both server-side (generator) and client-side (UI) contexts. Details The vulnerability exists in the DecodeStream class, which is the base class for all stream decoders including FlateStream (DEFLATE/zlib decompression). Unbounded buffer growth in ensureBuffer() — packages/pdf-lib/src/core/streams/DecodeStream.ts:148-160: The size = 2 loop has no maximum size check. The buffer will continue doubling until the process runs out of memory. Unconditional full decompression in decode() — DecodeStream.ts:139-141: FlateStream.readBlock() calls ensureBuffer() repeatedly during decompression —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vrqm-gvq7-rrwh

  2. Revision 1 · created ·

    Published from osv record GHSA-vrqm-gvq7-rrwh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82864

Advisory: PDFME Affected by Decompression Bomb in FlateDecode Stream Parsing Causes Memory Exhaustion DoS
IDs: CVE-2026-82864, GHSA-vrqm-gvq7-rrwh
Record: https://patchnext.com/advisories/cve-2026-82864 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @pdfme/pdf-lib 5.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @pdfme/pdf-lib: affected <= 5.5.9; fixed in 5.5.10

## Suggested inspection (read-only)
- `npm ls @pdfme/pdf-lib --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @pdfme/pdf-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrqm-gvq7-rrwh (OSV record GHSA-vrqm-gvq7-rrwh lists affected ranges: npm @pdfme/pdf-lib >=0 <5.5.10 (fixed))
- Verified: https://github.com/advisories/GHSA-vrqm-gvq7-rrwh (GitHub-reviewed advisory GHSA-vrqm-gvq7-rrwh lists affected ranges: npm @pdfme/pdf-lib >=0 <=5.5.9)

Commands are suggestions: review each one before running it.

Loading voting…