@hulumi/policies: CIS 1.16 admin policy bypass for inline and attached IAM policies
CVE-2026-82860GHSA-4xrh-5m3m-328w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/policies 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hulumi/policies
- Affected
- < 1.3.2
- Fixed in
- 1.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4xrh-5m3m-328w lists affected ranges: npm @hulumi/policies >=0 <1.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4xrh-5m3m-328w lists affected ranges: npm @hulumi/policies >=0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-82860: 0.54% estimated exploitation activity in the next 30 days; percentile 45.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact: @hulumi/policies versions before 1.3.2 did not fully inspect inline and attached IAM policy evidence for the administrator-policy guardrail, so some admin-equivalent policy paths could pass policy evaluation. Patched in 1.3.2: the validator inspects the affected policy shapes and includes regression tests. Remediation: upgrade @hulumi/policies to 1.3.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4xrh-5m3m-328w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4xrh-5m3m-328w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82860 Advisory: @hulumi/policies: CIS 1.16 admin policy bypass for inline and attached IAM policies IDs: CVE-2026-82860, GHSA-4xrh-5m3m-328w Record: https://patchnext.com/advisories/cve-2026-82860 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hulumi/policies 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hulumi/policies: affected < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - `npm ls @hulumi/policies --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hulumi/policies. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4xrh-5m3m-328w (OSV record GHSA-4xrh-5m3m-328w lists affected ranges: npm @hulumi/policies >=0 <1.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4xrh-5m3m-328w (GitHub-reviewed advisory GHSA-4xrh-5m3m-328w lists affected ranges: npm @hulumi/policies >=0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…