Skip to content

← Actionable
Medium, CVSS 4.9amended

Nodemailer Vulnerable to SMTP Command Injection via CRLF in Transport name Option (EHLO/HELO)

CVE-2026-82853GHSA-vvjj-xcjg-gr5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 8.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-82853: 1.03% estimated exploitation activity in the next 30 days; percentile 63.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Nodemailer versions up to and including 8.0.4 are vulnerable to SMTP command injection via CRLF sequences in the transport name configuration option. The name value is used directly in the EHLO/HELO SMTP command without any sanitization for carriage return and line feed characters (\r\n). An attacker who can influence this option can inject arbitrary SMTP commands, enabling unauthorized email sending, email spoofing, and phishing attacks. Details The vulnerability exists in lib/smtp-connection/index.js. When establishing an SMTP connection, the name option is concatenated directly into the EHLO command: The sendCommand method writes the string directly to the socket followed by \r\n (line 1082): If the name option contains \r\n sequences, each injected line is interpreted by the SMTP server as a separate command. Unlike the envelope.from and envelope.to fields which are validated for \r\n (line 1107-1119), and unlike envelope.size which was recently fixed…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vvjj-xcjg-gr5g

  2. Revision 1 · created ·

    Published from osv record GHSA-vvjj-xcjg-gr5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82853

Advisory: Nodemailer Vulnerable to SMTP Command Injection via CRLF in Transport name Option (EHLO/HELO)
IDs: CVE-2026-82853, GHSA-vvjj-xcjg-gr5g
Record: https://patchnext.com/advisories/cve-2026-82853 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 8.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected <= 8.0.4; fixed in 8.0.5

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vvjj-xcjg-gr5g (OSV record GHSA-vvjj-xcjg-gr5g lists affected ranges: npm nodemailer >=0 <8.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-vvjj-xcjg-gr5g (GitHub-reviewed advisory GHSA-vvjj-xcjg-gr5g lists affected ranges: npm nodemailer >=0 <=8.0.4)

Commands are suggestions: review each one before running it.

Loading voting…