bettercap Has an Integer Coercion Error in modules/mysql_server/mysql_server.go
CVE-2026-8276GHSA-jcqv-2g3v-gm88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/bettercap/bettercap/v2 2.41.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/bettercap/bettercap/v2
- Affected
- < 2.41.7
- Fixed in
- 2.41.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jcqv-2g3v-gm88 lists affected ranges: Go github.com/bettercap/bettercap/v2 >=0 <2.41.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-8276: 0.39% estimated exploitation activity in the next 30 days; percentile 33.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw has been found in bettercap up to 2.41.5. Affected by this issue is some unknown functionality of the file modules/mysqlserver/mysqlserver.go of the component MySQL Server. Executing a manipulation can lead to integer coercion error. The attack can be launched remotely. The attack requires a high level of complexity. The exploitation is known to be difficult. The exploit has been published and may be used. This patch is called 0eaa375c5e5446bfba94a290eff92967a5deac9e. It is advisable to implement a patch to correct this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jcqv-2g3v-gm88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8276 Advisory: bettercap Has an Integer Coercion Error in modules/mysql_server/mysql_server.go IDs: CVE-2026-8276, GHSA-jcqv-2g3v-gm88 Record: https://patchnext.com/advisories/cve-2026-8276 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/bettercap/bettercap/v2 2.41.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/bettercap/bettercap/v2: affected < 2.41.7; fixed in 2.41.7 ## Suggested inspection (read-only) - Go github.com/bettercap/bettercap/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/bettercap/bettercap/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jcqv-2g3v-gm88 (GitHub-reviewed advisory GHSA-jcqv-2g3v-gm88 lists affected ranges: Go github.com/bettercap/bettercap/v2 >=0 <2.41.7) Commands are suggestions: review each one before running it.
Loading voting…