Skip to content

← Actionable
Critical, CVSS 9.4amended

DeepSeek Harness contains an authentication bypass vulnerability in local HTTP control-plane API

CVE-2026-82533GHSA-8m2g-8cgm-3vcp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@deepseek-ai/dsh-client-connection 0.1.2-alpha.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-82533: 1.24% estimated exploitation activity in the next 30 days; percentile 69.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

DeepSeek Harness before 0.1.2-alpha.1 contains an authentication bypass vulnerability in its local HTTP control-plane API that allows attackers to gain full agent control by supplying a spoofed Host header, as the server validates only the client-supplied Host header value rather than the actual TCP connection origin. Attackers can exploit this flaw to invoke privileged commands such as commands/execute with danger-full-access permissions, escalate session approval policies to unconfined execution, and retrieve all stored conversations without any credential or API key.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-8m2g-8cgm-3vcp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8m2g-8cgm-3vcp

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8m2g-8cgm-3vcp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82533

Advisory: DeepSeek Harness contains an authentication bypass vulnerability in local HTTP control-plane API
IDs: CVE-2026-82533, GHSA-8m2g-8cgm-3vcp
Record: https://patchnext.com/advisories/cve-2026-82533 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @deepseek-ai/dsh-client-connection 0.1.2-alpha.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @deepseek-ai/dsh-client-connection: affected < 0.1.2-alpha.1; fixed in 0.1.2-alpha.1

## Suggested inspection (read-only)
- `npm ls @deepseek-ai/dsh-client-connection --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @deepseek-ai/dsh-client-connection.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8m2g-8cgm-3vcp (GitHub-reviewed advisory GHSA-8m2g-8cgm-3vcp lists affected ranges: npm @deepseek-ai/dsh-client-connection >=0 <0.1.2-alpha.1)
- Verified: https://osv.dev/vulnerability/GHSA-8m2g-8cgm-3vcp (OSV record GHSA-8m2g-8cgm-3vcp lists affected ranges: npm @deepseek-ai/dsh-client-connection >=0 <0.1.2-alpha.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…