qs: Denial of Service via Attacker Controlled isBuffer
CVE-2026-82417GHSA-4mjr-xmp4-gh2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (qs 6.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm qs
- Affected
- >= 2.2.5, < 6.16.0
- Fixed in
- 6.16.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mjr-xmp4-gh2g lists affected ranges: npm qs >=2.2.5 <6.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-82417: 0.40% estimated exploitation activity in the next 30 days; percentile 33.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary qs.stringify() calls utils.isBuffer() on every value it serializes, and utils.isBuffer() invokes obj.constructor.isBuffer(obj) without checking that it is callable. A value whose own constructor.isBuffer is a non-function makes qs call a non-callable and throw TypeError. Such a value is produced by qs.parse itself from an untrusted query string when plainObjects: true or allowPrototypes: true is set, so a pure-qs parse → stringify round-trip — no JSON.parse — turns an unauthenticated query string into an uncaught throw. An attacker-controlled parse input reaches the host application's availability asset — via qs's own recommended plainObjects mitigation — and triggers an uncaught exception during a parse → stringify round-trip. Details utils.isBuffer runs at lib/stringify.js:127 for every serialized value: utils.isBuffer (lib/utils.js:327-333) invokes obj.constructor.isBuffer without verifying it is callable: constructor and isBuffer are ordinary keys. qs.parse with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mjr-xmp4-gh2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82417 Advisory: qs: Denial of Service via Attacker Controlled isBuffer IDs: CVE-2026-82417, GHSA-4mjr-xmp4-gh2g Record: https://patchnext.com/advisories/cve-2026-82417 (revision 1, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: qs 6.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm qs: affected >= 2.2.5, < 6.16.0; fixed in 6.16.0 ## Suggested inspection (read-only) - `npm ls qs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on qs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mjr-xmp4-gh2g (GitHub-reviewed advisory GHSA-4mjr-xmp4-gh2g lists affected ranges: npm qs >=2.2.5 <6.16.0) Commands are suggestions: review each one before running it.
Loading voting…