Skip to content

← Actionable
High, CVSS 7.7amended

FrankenPHP: Cross-request PHP session ID leak in worker mode when the session extension is a shared module

CVE-2026-82416GHSA-v3ph-cgqh-r8p5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dunglas/frankenphp 1.12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-82416: 0.29% estimated exploitation activity in the next 30 days; percentile 21.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In worker mode under concurrency, FrankenPHP can hand a PHP session id from one request to another when PHP's session extension is loaded as a shared module instead of being statically linked into the FrankenPHP binary. A request presenting Cookie: session=A can have sessionid() resolve to B (a different concurrent client's id) or to a stale id from a previous request served by the same worker thread. Impact - Security: cross-user session exposure / session hijacking in worker mode. Same impact class as CVE-2026-24894. - Functional: users are intermittently logged out; their cookie's session is ignored and they receive a foreign or empty session. Affected / not affected Exposure is determined by how the session extension is linked in the PHP build FrankenPHP is compiled against, not by the FrankenPHP release: - Affected: any build where the session extension is not visible to FrankenPHP at compile time, i.e. loaded as a shared / out-of-tree module (extension=session in an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v3ph-cgqh-r8p5

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6797

  3. Revision 1 · created ·

    Published from osv record GHSA-v3ph-cgqh-r8p5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82416

Advisory: FrankenPHP: Cross-request PHP session ID leak in worker mode when the session extension is a shared module
IDs: CVE-2026-82416, GHSA-v3ph-cgqh-r8p5
Record: https://patchnext.com/advisories/cve-2026-82416 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/dunglas/frankenphp 1.12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/dunglas/frankenphp: affected <= 1.12.4; fixed in 1.12.5

## Suggested inspection (read-only)
- Go github.com/dunglas/frankenphp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/dunglas/frankenphp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6797 (OSV record GO-2026-6797 lists affected ranges: Go github.com/dunglas/frankenphp >=0 <1.12.5 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-v3ph-cgqh-r8p5 (OSV record GHSA-v3ph-cgqh-r8p5 lists affected ranges: Go github.com/dunglas/frankenphp >=0 <1.12.5 (fixed))
- Verified: https://github.com/advisories/GHSA-v3ph-cgqh-r8p5 (GitHub-reviewed advisory GHSA-v3ph-cgqh-r8p5 lists affected ranges: Go github.com/dunglas/frankenphp >=0 <=1.12.4)

Commands are suggestions: review each one before running it.

Loading voting…