Skip to content

← Actionable
Medium, CVSS 5.4amended

Sulu: Stored XSS via media download inline-disposition override

CVE-2026-82396GHSA-pp4x-ccxq-6r33

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sulu/sulu 3.0.8, 2.6.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sulu/sulu

    Affected
    <= 2.6.24>= 3.0.0-alpha1, < 3.0.8
    Fixed in
    3.0.8, 2.6.25

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-82396: 0.30% estimated exploitation activity in the next 30 days; percentile 22.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Stored Cross Site Scripting (XSS) in the media download endpoint. The download route (/media/{id}/download/{slug} and its admin variant) accepts the query parameter ?inline=1. When it is present, the response is sent with the header Content-Disposition: inline for any MIME type, which overrides the disposition rules the server would otherwise apply. By default, HTML and other scriptable uploads are not blocked, the file is served on the application origin with its stored Content-Type, and no X-Content-Type-Options or Content-Security-Policy header is sent. Because of this, an attacker can upload an HTML file and build a link that runs their own JavaScript in the context of the Sulu origin. Every installation where users who are not fully trusted can upload media is affected. This includes editors who hold the media add permission. Such an editor can store a payload that runs in the authenticated session of anyone who opens the link, including an administrator, which allows…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pp4x-ccxq-6r33

  2. Revision 1 · created ·

    Published from osv record GHSA-pp4x-ccxq-6r33

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-82396

Advisory: Sulu: Stored XSS via media download inline-disposition override
IDs: CVE-2026-82396, GHSA-pp4x-ccxq-6r33
Record: https://patchnext.com/advisories/cve-2026-82396 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sulu/sulu 3.0.8, 2.6.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sulu/sulu: affected <= 2.6.24; >= 3.0.0-alpha1, < 3.0.8; fixed in 3.0.8, 2.6.25

## Suggested inspection (read-only)
- Packagist sulu/sulu: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sulu/sulu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pp4x-ccxq-6r33 (OSV record GHSA-pp4x-ccxq-6r33 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0-alpha1 <3.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-pp4x-ccxq-6r33 (GitHub-reviewed advisory GHSA-pp4x-ccxq-6r33 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0-alpha1 <3.0.8)

Commands are suggestions: review each one before running it.

Loading voting…