pnpm: A tarball dependency's manifest name escapes node_modules → arbitrary file write/overwrite on install
CVE-2026-82393GHSA-vq4v-j7r6-jq4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.11.0, 10.34.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- < 10.34.5>= 11.0.0, < 11.11.0
- Fixed in
- 10.34.5, 11.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vq4v-j7r6-jq4m lists affected ranges: npm pnpm >=0 =11.0.0 <11.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-82393: 0.63% estimated exploitation activity in the next 30 days; percentile 50.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When resolving a package, pnpm uses the resolved manifest name as a raw path segment for the isolated-linker import target. A tarball dependency whose package.json name is a scoped path traversal (@x/../../…/<abs path) is therefore extracted outside nodemodules, to an attacker-chosen absolute path, and can overwrite existing files there. Attacker controls the destination, filenames, and contents → arbitrary file write → code execution (e.g. ~/.zshrc, .git/hooks/pre-commit, another package's code). Occurs during pnpm install even with --ignore-scripts (no lifecycle scripts run), defeating that safety. Same class as the just-patched GHSA-hwx4 (transitive-dependency alias traversal) and GHSA-v23m (stage download manifest name/version traversal), in a sink their fixes did not cover: the isolated-linker import target keyed by the resolved name. Root cause - The isolated-linker import target is built with a raw path.join(modules, <resolved name) in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vq4v-j7r6-jq4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82393 Advisory: pnpm: A tarball dependency's manifest `name` escapes node_modules → arbitrary file write/overwrite on install IDs: CVE-2026-82393, GHSA-vq4v-j7r6-jq4m Record: https://patchnext.com/advisories/cve-2026-82393 (revision 1, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 11.11.0, 10.34.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected < 10.34.5; >= 11.0.0, < 11.11.0; fixed in 10.34.5, 11.11.0 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vq4v-j7r6-jq4m (GitHub-reviewed advisory GHSA-vq4v-j7r6-jq4m lists affected ranges: npm pnpm >=0 =11.0.0 <11.11.0) Commands are suggestions: review each one before running it.
Loading voting…