pnpm: Virtual store linker path traversal via unvalidated depPath name in lockfileToDepGraph
CVE-2026-82392GHSA-c59q-g84q-2gj5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.11.0, 10.34.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- < 10.34.5>= 11.0.0, < 11.11.0
- Fixed in
- 10.34.5, 11.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c59q-g84q-2gj5 lists affected ranges: npm pnpm >=0 =11.0.0 <11.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-82392: 0.61% estimated exploitation activity in the next 30 days; percentile 49.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The virtual store linker constructs package installation directories using path.join(modules, pkgName) where pkgName is extracted from lockfile packages keys via dp.parse(depPath).name without validation. A crafted pnpm-lock.yaml with traversal sequences in depPath keys (e.g., ../../../tmp/pwned@1.0.0) causes package content to be written to arbitrary filesystem paths during pnpm install. This is an incomplete fix of GHSA-fr4h-3cph-29xv — the safeJoinModulesDir containment helper was applied to the hoisted linker and symlinkDependency but NOT to the virtual store linker's lockfileToDepGraph.ts:233. Details Root Cause dp.parse() at pnpm11/deps/path/src/index.ts:135 extracts the package name as: This is a raw substring operation with zero validation that name is a valid npm package name. A depPath of ../../../tmp/pwned@1.0.0 yields name = '../../../tmp/pwned'. Vulnerable Code Path 1. pnpm-lock.yaml → lockfile.packages['../../../../../../../tmp/pwned@1.0.0'] (attacker-controlled…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c59q-g84q-2gj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82392 Advisory: pnpm: Virtual store linker path traversal via unvalidated depPath name in lockfileToDepGraph IDs: CVE-2026-82392, GHSA-c59q-g84q-2gj5 Record: https://patchnext.com/advisories/cve-2026-82392 (revision 1, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 11.11.0, 10.34.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected < 10.34.5; >= 11.0.0, < 11.11.0; fixed in 10.34.5, 11.11.0 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c59q-g84q-2gj5 (GitHub-reviewed advisory GHSA-c59q-g84q-2gj5 lists affected ranges: npm pnpm >=0 =11.0.0 <11.11.0) Commands are suggestions: review each one before running it.
Loading voting…