multer vulnerable to Denial of Service via oversized array index in field names
CVE-2026-82333GHSA-535w-7cp7-47q4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (multer 2.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm multer
- Affected
- < 2.3.0
- Fixed in
- 2.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-535w-7cp7-47q4 lists affected ranges: npm multer >=0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-535w-7cp7-47q4 lists affected ranges: npm multer >=0 <2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-82333: 0.37% estimated exploitation activity in the next 30 days; percentile 30.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact multer is vulnerable to a Denial of Service (DoS) via a crafted array index in multipart field names. The append-field dependency parses bracket notation in field names, and a large numeric index such as items[4294967294] forces allocation of a maximum-length sparse array. A following field with a non-numeric key on the same base then converts that array to an object by iterating its full length, which consumes CPU synchronously and leaves the process unable to handle other requests. A single HTTP request with a crafted multipart body is sufficient to exploit this, and it affects multer 1.x and 2.x. Patches Users should upgrade to 2.3.0 and configure limits.fieldArrayIndexLimit to the minimum array index their application requires. Workarounds None.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-535w-7cp7-47q4
- Revision 2 · amended ·
Amended from osv record GHSA-535w-7cp7-47q4
- Revision 1 · created ·
Published from ghsa record GHSA-535w-7cp7-47q4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82333 Advisory: multer vulnerable to Denial of Service via oversized array index in field names IDs: CVE-2026-82333, GHSA-535w-7cp7-47q4 Record: https://patchnext.com/advisories/cve-2026-82333 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: multer 2.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm multer: affected < 2.3.0; fixed in 2.3.0 ## Suggested inspection (read-only) - `npm ls multer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on multer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-535w-7cp7-47q4 (GitHub-reviewed advisory GHSA-535w-7cp7-47q4 lists affected ranges: npm multer >=0 <2.3.0) - Verified: https://osv.dev/vulnerability/GHSA-535w-7cp7-47q4 (OSV record GHSA-535w-7cp7-47q4 lists affected ranges: npm multer >=0 <2.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…