CPU exhaustion in SvelteKit remote form deserialization (experimental only)
CVE-2026-82261GHSA-88qp-p4qg-rqm6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.52.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sveltejs/kit
- Affected
- >= 2.49.0, <= 2.52.1
- Fixed in
- 2.52.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-88qp-p4qg-rqm6 lists affected ranges: npm @sveltejs/kit >=2.49.0 <2.52.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-88qp-p4qg-rqm6 lists affected ranges: npm @sveltejs/kit >=2.49.0 <=2.52.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-82261: 0.49% estimated exploitation activity in the next 30 days; percentile 42.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of @sveltejs/kit prior to 2.52.2 with remote functions enabled are vulnerable to CPU exhaustion. Malformed form data can cause the server to become unresponsive while processing a request, resulting in denial of service. Only applications using both experimental.remoteFunctions and form are vulnerable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-88qp-p4qg-rqm6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-88qp-p4qg-rqm6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82261 Advisory: CPU exhaustion in SvelteKit remote form deserialization (experimental only) IDs: CVE-2026-82261, GHSA-88qp-p4qg-rqm6 Record: https://patchnext.com/advisories/cve-2026-82261 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.52.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sveltejs/kit: affected >= 2.49.0, <= 2.52.1; fixed in 2.52.2 ## Suggested inspection (read-only) - `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sveltejs/kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-88qp-p4qg-rqm6 (OSV record GHSA-88qp-p4qg-rqm6 lists affected ranges: npm @sveltejs/kit >=2.49.0 <2.52.2 (fixed)) - Verified: https://github.com/advisories/GHSA-88qp-p4qg-rqm6 (GitHub-reviewed advisory GHSA-88qp-p4qg-rqm6 lists affected ranges: npm @sveltejs/kit >=2.49.0 <=2.52.1) Commands are suggestions: review each one before running it.
Loading voting…