@sveltejs/kit: query.batch cross-talk
CVE-2026-82258GHSA-hgv7-v322-mmgr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.60.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sveltejs/kit
- Affected
- >= 2.38.0, <= 2.60.0
- Fixed in
- 2.60.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgv7-v322-mmgr lists affected ranges: npm @sveltejs/kit >=2.38.0 <2.60.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgv7-v322-mmgr lists affected ranges: npm @sveltejs/kit >=2.38.0 <=2.60.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-82258: 0.24% estimated exploitation activity in the next 30 days; percentile 14.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
query.batch() could, under very rare and specific timings, cause concurrent requests from different users to merge and resolve under single request context, enabling cross-user data disclosure.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hgv7-v322-mmgr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hgv7-v322-mmgr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-82258 Advisory: @sveltejs/kit: `query.batch` cross-talk IDs: CVE-2026-82258, GHSA-hgv7-v322-mmgr Record: https://patchnext.com/advisories/cve-2026-82258 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.60.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sveltejs/kit: affected >= 2.38.0, <= 2.60.0; fixed in 2.60.1 ## Suggested inspection (read-only) - `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sveltejs/kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgv7-v322-mmgr (OSV record GHSA-hgv7-v322-mmgr lists affected ranges: npm @sveltejs/kit >=2.38.0 <2.60.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hgv7-v322-mmgr (GitHub-reviewed advisory GHSA-hgv7-v322-mmgr lists affected ranges: npm @sveltejs/kit >=2.38.0 <=2.60.0) Commands are suggestions: review each one before running it.
Loading voting…