Skip to content

← Actionable
Low, CVSS 1.9

OSGeo gdal has a heap-based buffer overflow

CVE-2026-8212GHSA-r5m4-5vww-w9f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gdal 3.13.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gdal

    Affected
    < 3.13.0rc1
    Fixed in
    3.13.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-8212: 0.21% estimated exploitation activity in the next 30 days; percentile 10.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch commit sha is 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r5m4-5vww-w9f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8212

Advisory: OSGeo gdal has a heap-based buffer overflow
IDs: CVE-2026-8212, GHSA-r5m4-5vww-w9f5
Record: https://patchnext.com/advisories/cve-2026-8212 (revision 1, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gdal 3.13.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gdal: affected < 3.13.0rc1; fixed in 3.13.0rc1

## Suggested inspection (read-only)
- `python -m pip show gdal`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gdal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5m4-5vww-w9f5 (GitHub-reviewed advisory GHSA-r5m4-5vww-w9f5 lists affected ranges: PyPI gdal >=0 <3.13.0rc1)

Commands are suggestions: review each one before running it.

Loading voting…