Skip to content

← Actionable
Medium, CVSS 5.1amended

Livewire DOM-based cross-site scripting during client-side state handling

CVE-2026-81887GHSA-g3hc-697w-wm82

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (livewire/livewire 4.3.4, 3.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist livewire/livewire

    Affected
    >= 3.0.0-beta.1, <= 3.8.2>= 4.0.0-beta.1, <= 4.3.3
    Fixed in
    4.3.4, 3.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-81887: 0.68% estimated exploitation activity in the next 30 days; percentile 52.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Livewire v3 (≤ 3.8.2) and v4 (≤ 4.3.3), a vulnerability allows unauthenticated attackers to execute arbitrary JavaScript in the origin of an affected application in specific scenarios. The issue stems from how certain client-side component state is handled. This vulnerability does not affect prior major versions. Exploitation requires user interaction, but does not require authentication or prior access to the application. The issue does not bypass server-side authorisation and grants an attacker no privileges beyond those the affected user already holds. Patches This issue has been patched in Livewire v3.8.3 and v4.3.4. All users are strongly encouraged to upgrade to these versions or later as soon as possible. Workarounds There is no known workaround at this time. Users are strongly advised to upgrade to a patched version immediately.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g3hc-697w-wm82

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g3hc-697w-wm82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-81887

Advisory: Livewire DOM-based cross-site scripting during client-side state handling
IDs: CVE-2026-81887, GHSA-g3hc-697w-wm82
Record: https://patchnext.com/advisories/cve-2026-81887 (revision 3, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: livewire/livewire 4.3.4, 3.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist livewire/livewire: affected >= 3.0.0-beta.1, <= 3.8.2; >= 4.0.0-beta.1, <= 4.3.3; fixed in 4.3.4, 3.8.3

## Suggested inspection (read-only)
- Packagist livewire/livewire: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on livewire/livewire.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g3hc-697w-wm82 (OSV record GHSA-g3hc-697w-wm82 lists affected ranges: Packagist livewire/livewire >=3.0.0-beta.1 =4.0.0-beta.1 <4.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g3hc-697w-wm82 (GitHub-reviewed advisory GHSA-g3hc-697w-wm82 lists affected ranges: Packagist livewire/livewire >=3.0.0-beta.1 =4.0.0-beta.1 <=4.3.3)

Commands are suggestions: review each one before running it.

Loading voting…