HAPI FHIR: SHCParser DEFLATE infinite loop causes denial of service
CVE-2026-81876GHSA-gq9c-wmrm-5hvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli 6.9.12; ca.uhn.hapi.fhir:org.hl7.fhir.validation 6.9.12; ca.uhn.hapi.fhir:org.hl7.fhir.r5 6.9.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli
- Affected
- <= 6.9.11
- Fixed in
- 6.9.12
Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation
- Affected
- <= 6.9.11
- Fixed in
- 6.9.12
Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5
- Affected
- <= 6.9.11
- Fixed in
- 6.9.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gq9c-wmrm-5hvr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <6.9.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gq9c-wmrm-5hvr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=6.9.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-81876: 0.63% estimated exploitation activity in the next 30 days; percentile 50.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A malformed Smart Health Card (SHC) JWT with zip: "DEF" and an empty or truncated DEFLATE payload causes SHCParser.inflate() to loop forever. This allows an attacker who can submit SHC content for validation to pin a JVM worker thread indefinitely, causing denial of service. Details The vulnerable code is in org.hl7.fhir.r5/src/main/java/org/hl7/fhir/r5/elementmodel/SHCParser.java. decodeJWT() inflates the JWT payload when the header contains "zip":"DEF": inflate() loops only on !inflater.finished() and does not check inflater.needsInput(), inflater.needsDictionary(), or zero-progress output: For empty or truncated raw DEFLATE input, Inflater.inflate() returns 0, finished() remains false, and needsInput() becomes true, producing an infinite tight loop. The same unsafe loop pattern also exists in decompress() at SHCParser.java:410-423. The validator reaches this path during SHC validation and during file-format detection for SHC-looking input (ResourceChecker.java:115-118).…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gq9c-wmrm-5hvr
- Revision 1 · created ·
Published from osv record GHSA-gq9c-wmrm-5hvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-81876 Advisory: HAPI FHIR: SHCParser DEFLATE infinite loop causes denial of service IDs: CVE-2026-81876, GHSA-gq9c-wmrm-5hvr Record: https://patchnext.com/advisories/cve-2026-81876 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli 6.9.12; ca.uhn.hapi.fhir:org.hl7.fhir.validation 6.9.12; ca.uhn.hapi.fhir:org.hl7.fhir.r5 6.9.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: affected <= 6.9.11; fixed in 6.9.12 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: affected <= 6.9.11; fixed in 6.9.12 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: affected <= 6.9.11; fixed in 6.9.12 ## Suggested inspection (read-only) - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli, ca.uhn.hapi.fhir:org.hl7.fhir.validation, ca.uhn.hapi.fhir:org.hl7.fhir.r5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gq9c-wmrm-5hvr (OSV record GHSA-gq9c-wmrm-5hvr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <6.9.12 (fixed)) - Verified: https://github.com/advisories/GHSA-gq9c-wmrm-5hvr (GitHub-reviewed advisory GHSA-gq9c-wmrm-5hvr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=6.9.11) Commands are suggestions: review each one before running it.
Loading voting…