HAPI FHIR: SHCParser unbounded DEFLATE decompression causes denial of service
CVE-2026-81875GHSA-3w98-rrpr-fprr
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli
- Affected
- <= 5.0.0
- Fixed in
- no fixed version recorded
Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation
- Affected
- <= 6.9.11
- Fixed in
- 6.9.12
Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5
- Affected
- <= 6.9.11
- Fixed in
- 6.9.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3w98-rrpr-fprr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=5.0.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3w98-rrpr-fprr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-81875: 0.63% estimated exploitation activity in the next 30 days; percentile 50.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary SHCParser inflates compressed Smart Health Card JWT payloads into memory without a decompressed-size limit. An attacker who can submit SHC content for validation can craft a small compressed JWT payload that expands to a very large byte array, causing memory exhaustion or severe garbage collection pressure. Details The vulnerable code is in org.hl7.fhir.r5/src/main/java/org/hl7/fhir/r5/elementmodel/SHCParser.java. decodeJWT() checks MAXALLOWEDSHCLENGTH, but this only logs an error and parsing continues: If the header contains "zip":"DEF", the payload is inflated before JSON parsing: inflate() accumulates all decompressed output in a ByteArrayOutputStream and has no maximum output size: The same unbounded decompression pattern exists in decompress() at SHCParser.java:410-423. PoC Create a highly compressible SHC-shaped JSON payload, compress it with raw DEFLATE (new Deflater(9, true)), Base64URL-encode it as the JWT payload, and set the JWT header to {"zip":"DEF"}. Local…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3w98-rrpr-fprr
- Revision 1 · created ·
Published from osv record GHSA-3w98-rrpr-fprr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-81875 Advisory: HAPI FHIR: SHCParser unbounded DEFLATE decompression causes denial of service IDs: CVE-2026-81875, GHSA-3w98-rrpr-fprr Record: https://patchnext.com/advisories/cve-2026-81875 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: ca.uhn.hapi.fhir:org.hl7.fhir.validation 6.9.12; ca.uhn.hapi.fhir:org.hl7.fhir.r5 6.9.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: affected <= 5.0.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: affected <= 6.9.11; fixed in 6.9.12 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: affected <= 6.9.11; fixed in 6.9.12 ## Suggested inspection (read-only) - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli, ca.uhn.hapi.fhir:org.hl7.fhir.validation, ca.uhn.hapi.fhir:org.hl7.fhir.r5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3w98-rrpr-fprr (OSV record GHSA-3w98-rrpr-fprr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=5.0.0) - Verified: https://github.com/advisories/GHSA-3w98-rrpr-fprr (GitHub-reviewed advisory GHSA-3w98-rrpr-fprr lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5 >=0 =0 =0 <=5.0.0) Commands are suggestions: review each one before running it.
Loading voting…