Skip to content

← Actionable
High, CVSS 8.3amended

NLTK: Model-artifact APIs bypass pathsec and touch files outside allowed roots

CVE-2026-81726GHSA-8mgp-746c-j5xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    < 3.10.4
    Fixed in
    3.10.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-81726: 0.34% estimated exploitation activity in the next 30 days; percentile 27.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Several model-artifact APIs still treat caller-controlled model paths as ordinary filenames even when NLTK path security is enforced. The same outside-root paths are rejected by guarded helpers, but these public read and write flows still use raw file APIs.

Details - Vulnerability type: File sandbox bypass - Affected component: `TransitionParser.train`, `TransitionParser.parse`, `AveragedPerceptron.save`, `AveragedPerceptron.load`, `PerceptronTagger.save_to_json`, `save_maxent_params` - Affected versions: Published `3.9.4` and current source `v3.10.0-rc2` both reproduced. - Patched versions: Not yet patched - Root cause: Model import and export helpers use built-in `open()` on caller-controlled paths instead of pathsec-aware helpers. `TransitionParser.train()` writes outside allowed roots, `TransitionParser.parse()` reads outside allowed roots, `AveragedPerceptron` bypasses the sandbox in both directions, and adjacent read-side helpers in the same…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-8mgp-746c-j5xp

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-8mgp-746c-j5xp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8mgp-746c-j5xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-81726

Advisory: NLTK: Model-artifact APIs bypass pathsec and touch files outside allowed roots
IDs: CVE-2026-81726, GHSA-8mgp-746c-j5xp
Record: https://patchnext.com/advisories/cve-2026-81726 (revision 3, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected < 3.10.4; fixed in 3.10.4

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8mgp-746c-j5xp (GitHub-reviewed advisory GHSA-8mgp-746c-j5xp lists affected ranges: PyPI nltk >=0 <=3.10.3)
- Verified: https://osv.dev/vulnerability/GHSA-8mgp-746c-j5xp (OSV record GHSA-8mgp-746c-j5xp lists affected ranges: PyPI nltk >=0 <3.10.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…