Skip to content

← Actionable
Medium, CVSS 6.3amended

NLTK: Pl196xCorpusReader has quadratic ReDoS on malformed TEI blocks

CVE-2026-81725GHSA-8mpw-7fpc-4gqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    <= 3.10.2
    Fixed in
    3.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-81725: 0.37% estimated exploitation activity in the next 30 days; percentile 30.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Pl196xCorpusReader still parses whole TEI blocks with multiple lazy regexes over attacker-controlled text. A malformed file with many opening tags and no matching closing tags forces repeated rescans and produces quadratic CPU growth in public reader APIs. Details - Vulnerability type: Regular-expression denial of service - Affected component: nltk.corpus.reader.pl196x.TEICorpusView.readblock and Pl196xCorpusReader public methods - Affected versions: Published 3.9.4 and current source v3.10.0-rc2 both reproduced. - Patched versions: Not yet patched - Root cause: Lazy .? whole-block regexes rescan untrusted XML-like blocks from each opening-tag position. The parser uses regexes for paragraphs, sentences, and word tags across the whole <text block. When the attacker supplies many unmatched opening tags, each attempt scans toward the end of the block and fails, then restarts from the next opening tag. There is near four-times runtime growth each time the number of malformed <p…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-8mpw-7fpc-4gqj

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8mpw-7fpc-4gqj

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8mpw-7fpc-4gqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-81725

Advisory: NLTK: Pl196xCorpusReader has quadratic ReDoS on malformed TEI blocks
IDs: CVE-2026-81725, GHSA-8mpw-7fpc-4gqj
Record: https://patchnext.com/advisories/cve-2026-81725 (revision 4, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected <= 3.10.2; fixed in 3.10.3

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8mpw-7fpc-4gqj (GitHub-reviewed advisory GHSA-8mpw-7fpc-4gqj lists affected ranges: PyPI nltk >=0 <=3.10.2)
- Verified: https://osv.dev/vulnerability/GHSA-8mpw-7fpc-4gqj (OSV record GHSA-8mpw-7fpc-4gqj lists affected ranges: PyPI nltk >=0 <3.10.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…