multiparty vulnerable to Denial of Service via Uncaught Exception in filename* parameter parsing
CVE-2026-8162GHSA-xh3c-6gcq-g4rv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (multiparty 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm multiparty
- Affected
- <= 4.2.3
- Fixed in
- 4.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xh3c-6gcq-g4rv lists affected ranges: npm multiparty >=0 <4.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xh3c-6gcq-g4rv lists affected ranges: npm multiparty >=0 <=4.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-8162: 0.33% estimated exploitation activity in the next 30 days; percentile 25.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact multiparty@4.2.3 and lower versions are vulnerable to denial of service via uncaught exception. By sending a multipart/form-data request with a Content-Disposition: filename=utf-8'' header containing a malformed percent-encoding (e.g., %FF, %GG), the parser invokes decodeURI on the value without try/catch. The resulting URIError propagates as an uncaught exception and crashes the process. Any service accepting multipart uploads via multiparty is affected. Patches Users should upgrade to multiparty@4.3.0 or higher. Workarounds None.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xh3c-6gcq-g4rv
- Revision 1 · created ·
Published from osv record GHSA-xh3c-6gcq-g4rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8162 Advisory: multiparty vulnerable to Denial of Service via Uncaught Exception in filename* parameter parsing IDs: CVE-2026-8162, GHSA-xh3c-6gcq-g4rv Record: https://patchnext.com/advisories/cve-2026-8162 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: multiparty 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm multiparty: affected <= 4.2.3; fixed in 4.3.0 ## Suggested inspection (read-only) - `npm ls multiparty --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on multiparty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xh3c-6gcq-g4rv (OSV record GHSA-xh3c-6gcq-g4rv lists affected ranges: npm multiparty >=0 <4.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xh3c-6gcq-g4rv (GitHub-reviewed advisory GHSA-xh3c-6gcq-g4rv lists affected ranges: npm multiparty >=0 <=4.2.3) Commands are suggestions: review each one before running it.
Loading voting…