Skip to content

← Actionable
High, CVSS 8.1amended

MLflow: trace API endpoints lack proper authorization validators

CVE-2026-8147GHSA-2cm6-r77w-6g96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.13.0rc0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlflow

    Affected
    >= 2.14.0rc0, < 3.13.0rc0
    Fixed in
    3.13.0rc0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-8147: 0.55% estimated exploitation activity in the next 30 days; percentile 45.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In MLflow versions prior to 3.13.0, when running with authentication enabled, the trace API endpoints lack proper authorization validators. This allows any authenticated user to bypass experiment-level authorization controls on all trace operations, including reading, deleting, and modifying traces on experiments they do not have permission to access. The issue arises from the beforerequest handler, which does not register authorization validators for trace endpoints, resulting in requests proceeding without validation. This vulnerability can expose sensitive data, destroy audit logs, and allow unauthorized modifications.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2cm6-r77w-6g96

  2. Revision 1 · created ·

    Published from osv record GHSA-2cm6-r77w-6g96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-8147

Advisory: MLflow: trace API endpoints lack proper authorization validators
IDs: CVE-2026-8147, GHSA-2cm6-r77w-6g96
Record: https://patchnext.com/advisories/cve-2026-8147 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mlflow 3.13.0rc0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlflow: affected >= 2.14.0rc0, < 3.13.0rc0; fixed in 3.13.0rc0

## Suggested inspection (read-only)
- `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2cm6-r77w-6g96 (OSV record GHSA-2cm6-r77w-6g96 lists affected ranges: PyPI mlflow >=2.14.0rc0 <3.13.0rc0 (fixed))
- Verified: https://github.com/advisories/GHSA-2cm6-r77w-6g96 (GitHub-reviewed advisory GHSA-2cm6-r77w-6g96 lists affected ranges: PyPI mlflow >=2.14.0rc0 <3.13.0rc0)

Commands are suggestions: review each one before running it.

Loading voting…