OSGeo GDAL vulnerable to heap-based buffer overflow
CVE-2026-8087GHSA-h9rh-5ffh-h669
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gdal 3.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gdal
- Affected
- < 3.13.0
- Fixed in
- 3.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h9rh-5ffh-h669 lists affected ranges: PyPI gdal >=0 <3.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9rh-5ffh-h669 lists affected ranges: PyPI gdal >=0 <3.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-8087: 0.22% estimated exploitation activity in the next 30 days; percentile 12.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security flaw has been discovered in OSGeo gdal up to 3.13.0dev-4. Impacted is the function GDnentries of the file frmts/hdf4/hdf-eos/GDapi.c. Performing a manipulation of the argument DataFieldName results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.13.0RC1 is recommended to address this issue. The patch is named 184f77dbcc74118c062c05e464c88161d3c37b9b. You should upgrade the affected component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h9rh-5ffh-h669
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h9rh-5ffh-h669
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8087 Advisory: OSGeo GDAL vulnerable to heap-based buffer overflow IDs: CVE-2026-8087, GHSA-h9rh-5ffh-h669 Record: https://patchnext.com/advisories/cve-2026-8087 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gdal 3.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gdal: affected < 3.13.0; fixed in 3.13.0 ## Suggested inspection (read-only) - `python -m pip show gdal`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gdal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h9rh-5ffh-h669 (OSV record GHSA-h9rh-5ffh-h669 lists affected ranges: PyPI gdal >=0 <3.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h9rh-5ffh-h669 (GitHub-reviewed advisory GHSA-h9rh-5ffh-h669 lists affected ranges: PyPI gdal >=0 <3.13.0) Commands are suggestions: review each one before running it.
Loading voting…