Skip to content

← Actionable
High, CVSS 8.9amended

amqp091-go has a Potential Memory Exhaustion/Protocol Violation via Broker-Controlled Oversized Payload

CVE-2026-79921GHSA-6c5v-hqjr-5xxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
EPSS
  • CVE-2026-79921: 0.55% estimated exploitation activity in the next 30 days; percentile 46.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability exists in the amqp091-go client library where a compromised or malicious AMQP broker can force the client to allocate resources for and process content body frames that exceed the negotiated framemax limit. This can lead to unexpected memory consumption or application-layer denial of service (DoS), bypassing the protocol's built-in framing constraints. Details During a standard AMQP 0-9-1 connection handshake, the client and the broker negotiate a maximum frame size (framemax), for example, 4096 bytes. However, after negotiation, a malicious broker can send a valid basic.deliver sequence containing a content body frame whose header declares a payload size larger than the negotiated framemax. Instead of enforcing the agreed-upon limit and closing the connection with a frame-error (as mandated by the AMQP 0-9-1 specification), the amqp091-go client: 1. Accepts the broker-declared oversized frame size. 2. Allocates memory based on this oversized declaration. 3.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-6c5v-hqjr-5xxp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6372

  4. Revision 1 · created ·

    Published from osv record GHSA-6c5v-hqjr-5xxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-79921

Advisory: amqp091-go has a Potential Memory Exhaustion/Protocol Violation via Broker-Controlled Oversized Payload
IDs: CVE-2026-79921, GHSA-6c5v-hqjr-5xxp
Record: https://patchnext.com/advisories/cve-2026-79921 (revision 4, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rabbitmq/amqp091-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6c5v-hqjr-5xxp (OSV record GHSA-6c5v-hqjr-5xxp lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6372 (OSV record GO-2026-6372 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6c5v-hqjr-5xxp (GitHub-reviewed advisory GHSA-6c5v-hqjr-5xxp lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…