Skip to content

← Actionable
Medium, CVSS 4.9amended

Winter: Local File Inclusion through =include directives in JavaScript asset compilation

CVE-2026-79773GHSA-2223-f22x-24cq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-system-module 1.2.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-79773: 0.49% estimated exploitation activity in the next 30 days; percentile 42.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Affected versions of Winter CMS allow authenticated backend users with the cms.manageassets permission ("Manage website assets - images, JavaScript files, CSS files") to disclose arbitrary files readable by the PHP process by placing an =include / =require directive in a theme JavaScript asset. Winter\Storm\Parse\Assetic\Filter\JavascriptImporter processes =include / =require directives found in comment blocks of JavaScript assets passed through System\Classes\CombineAssets. The directive target was resolved relative to the including file's own directory with realpath() and inlined into the combined output with no confinement check, so a directive such as =include ../../../.env escaped the theme's asset tree and inlined an arbitrary server-readable file. The only restriction was that the target had to have a file extension, since extension-less names had .js appended to them. Because the combined output is served through the combine/{file} route, which performs no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2223-f22x-24cq

  2. Revision 1 · created ·

    Published from osv record GHSA-2223-f22x-24cq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-79773

Advisory: Winter: Local File Inclusion through =include directives in JavaScript asset compilation
IDs: CVE-2026-79773, GHSA-2223-f22x-24cq
Record: https://patchnext.com/advisories/cve-2026-79773 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-system-module 1.2.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-system-module: affected < 1.2.13; fixed in 1.2.13

## Suggested inspection (read-only)
- Packagist winter/wn-system-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-system-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2223-f22x-24cq (OSV record GHSA-2223-f22x-24cq lists affected ranges: Packagist winter/wn-system-module >=0 <1.2.13 (fixed))
- Verified: https://github.com/advisories/GHSA-2223-f22x-24cq (GitHub-reviewed advisory GHSA-2223-f22x-24cq lists affected ranges: Packagist winter/wn-system-module >=0 <1.2.13)

Commands are suggestions: review each one before running it.

Loading voting…