Skip to content

← Actionable
Medium, CVSS 5.3

Nokogiri does not check the return value from xmlC14NExecute

CVE-2026-79772GHSA-wx95-c6cv-8532

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    >= 1.5.1, < 1.19.1
    Fixed in
    1.19.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-79772: 0.34% estimated exploitation activity in the next 30 days; percentile 27.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Nokogiri's CRuby extension fails to check the return value from xmlC14NExecute in the method Nokogiri::XML::Document#canonicalize and Nokogiri::XML::Node#canonicalize. When canonicalization fails, an empty string is returned instead of raising an exception. This incorrect return value may allow downstream libraries to accept invalid or incomplete canonicalized XML, which has been demonstrated to enable signature validation bypass in SAML libraries. JRuby is not affected, as the Java implementation correctly raises RuntimeError on canonicalization failure. Mitigation Upgrade to Nokogiri = 1.19.1. Severity The maintainers have assessed this as Medium severity. Nokogiri itself is a parsing library without a clear security boundary related to canonicalization, so the direct impact is that a method returns incorrect data on invalid input. However, this behavior was exploited in practice to bypass SAML signature validation in downstream libraries (see References). Credit This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wx95-c6cv-8532

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-79772

Advisory: Nokogiri does not check the return value from xmlC14NExecute
IDs: CVE-2026-79772, GHSA-wx95-c6cv-8532
Record: https://patchnext.com/advisories/cve-2026-79772 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected >= 1.5.1, < 1.19.1; fixed in 1.19.1

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wx95-c6cv-8532 (GitHub-reviewed advisory GHSA-wx95-c6cv-8532 lists affected ranges: RubyGems nokogiri >=1.5.1 <1.19.1)

Commands are suggestions: review each one before running it.

Loading voting…