Nokogiri XSLT transform has a memory leak
CVE-2026-79771GHSA-v2fc-qm4h-8hqv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.19.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems nokogiri
- Affected
- < 1.19.3
- Fixed in
- 1.19.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2fc-qm4h-8hqv lists affected ranges: RubyGems nokogiri >=0 <1.19.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-79771: 0.42% estimated exploitation activity in the next 30 days; percentile 36.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Nokogiri's Nokogiri::XSLT::Stylesheet#transform leaks a small heap allocation when passed a Ruby string parameter containing a null byte. For applications that pass attacker-controlled input through XSLT.transform parameters, this may be a vector for a denial of service attack against long-running processes. Mitigation Upgrade to Nokogiri = 1.19.3. Users may also be able to mitigate this issue without upgrading by validating untrusted transform parameters before passing them to Nokogiri::XSLT::Stylesheet#transform. Severity The Nokogiri maintainers have evaluated this as Moderate Severity, CVSS 5.3. Each leaked allocation is approximately 24–32 bytes, so meaningful memory growth requires sustained attacker-controlled traffic at high call rates. The bug does not cause memory corruption, information disclosure, or any change in the behavior of the transform itself, and the string-handling exception is raised as expected. Applications that do not pass raw attacker-controlled…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v2fc-qm4h-8hqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-79771 Advisory: Nokogiri XSLT transform has a memory leak IDs: CVE-2026-79771, GHSA-v2fc-qm4h-8hqv Record: https://patchnext.com/advisories/cve-2026-79771 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.19.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems nokogiri: affected < 1.19.3; fixed in 1.19.3 ## Suggested inspection (read-only) - RubyGems nokogiri: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nokogiri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v2fc-qm4h-8hqv (GitHub-reviewed advisory GHSA-v2fc-qm4h-8hqv lists affected ranges: RubyGems nokogiri >=0 <1.19.3) Commands are suggestions: review each one before running it.
Loading voting…