Skip to content

← Actionable
Critical, CVSS 9.4amended

NLTK: Unsafe Pickle Deserialization in TransitionParser Allows Remote Code Execution

CVE-2026-78683GHSA-rhp5-r9x4-f5g2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    <= 3.9.4
    Fixed in
    3.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-78683: 0.51% estimated exploitation activity in the next 30 days; percentile 43.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The NLTK library's TransitionParser.parse() method deserializes model files using pickleload() with the default restricted=False parameter, allowing arbitrary Python code execution when loading a malicious model file. The library provides a RestrictedUnpickler class for safe deserialization, but it is never used by production code paths, leaving the vulnerability unpatched. Root Cause File: nltk/parse/transitionparser.py (lines 542-557) The parse() method calls pickleload(f) without restricted=True, routing through WarningUnpickler which inherits from pickle.Unpickler and does NOT override findclass(). This allows arbitrary class/function resolution during unpickling, enabling RCE via standard pickle gadgets (e.g., os.system, subprocess.Popen). Vulnerability chain in nltk/picklesec.py: WarningUnpickler only emits a warning but does NOT block unsafe class loading — it calls super().load() which is standard pickle.Unpickler.load(). Why this is not by design: - NLTK…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-rhp5-r9x4-f5g2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-rhp5-r9x4-f5g2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-rhp5-r9x4-f5g2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-78683

Advisory: NLTK: Unsafe Pickle Deserialization in TransitionParser Allows Remote Code Execution
IDs: CVE-2026-78683, GHSA-rhp5-r9x4-f5g2
Record: https://patchnext.com/advisories/cve-2026-78683 (revision 4, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected <= 3.9.4; fixed in 3.10.0

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rhp5-r9x4-f5g2 (GitHub-reviewed advisory GHSA-rhp5-r9x4-f5g2 lists affected ranges: PyPI nltk >=0 <=3.9.4)
- Verified: https://osv.dev/vulnerability/GHSA-rhp5-r9x4-f5g2 (OSV record GHSA-rhp5-r9x4-f5g2 lists affected ranges: PyPI nltk >=0 <3.10.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…