Skip to content

← Actionable
High, CVSS 7.3amended

zbus_polkit: authorization bypass via PID reuse

CVE-2026-78422

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zbus_polkit 5.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zbus_polkit

    Affected
    >= 0.0.0-0, < 5.1.0
    Fixed in
    5.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-78422: 0.13% estimated exploitation activity in the next 30 days; percentile 2.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

`Subject::new_for_owner()` in the `zbus_polkit` crate encodes the uid entry of a unix-process polkit subject as an unsigned 32-bit integer (D-Bus type u), whereas the org.freedesktop.PolicyKit1.Authority interface specifies a signed 32-bit integer (D-Bus type i). Because of this type mismatch, polkit silently discards the caller-supplied UID and instead determines the subject's owner itself by looking up the PID in /proc, a lookup that is inherently subject to a time-of-check/time-of-use race. Consequently, an application that passes a UID obtained from a trustworthy source — for example `SO_PEERCRED` Unix socket peer credentials — in order to defend against PID reuse receives no protection, and the supplied UID has no effect on the authorization decision. A local unprivileged attacker who can cause an authorized process to terminate and then win the race to have their own process assigned the same PID can be authorized under the identity of the terminated process, bypassing the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0278

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-78422

Advisory: `zbus_polkit`: authorization bypass via PID reuse
IDs: CVE-2026-78422
Record: https://patchnext.com/advisories/cve-2026-78422 (revision 2, source checked 25 Oct 2026, 04:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zbus_polkit 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zbus_polkit: affected >= 0.0.0-0, < 5.1.0; fixed in 5.1.0

## Suggested inspection (read-only)
- crates.io zbus_polkit: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zbus_polkit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0278 (OSV record RUSTSEC-2026-0278 lists affected ranges: crates.io zbus_polkit >=0.0.0-0 <5.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…