Skip to content

← Actionable
High, CVSS 7.3amended

pgAdmin 4 has deserialization of untrusted data in its FileBackedSessionManager

CVE-2026-7818GHSA-4rhg-h8f2-v4jm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgadmin4 9.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-7818: 0.13% estimated exploitation activity in the next 30 days; percentile 2.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Deserialization of untrusted data (CWE-502) in pgAdmin 4 FileBackedSessionManager. The session manager performed unsafe deserialization of session-file contents (using Python's standard object-serialization module) before performing any HMAC integrity check. Any file dropped into the sessions directory was deserialized unconditionally. An authenticated user with write access to the sessions directory (whether by misconfiguration or in combination with another path-traversal flaw) could plant a crafted serialized payload to achieve operating-system level remote code execution under the pgAdmin process identity. Fix prepends a 64-byte hex SHA-256 HMAC over the session body, computed with SECRETKEY, and verifies it via hmac.comparedigest before any deserialization. The check is raised (rather than asserted) on empty SECRETKEY so it is not stripped under -O. This issue affects pgAdmin 4: before 9.15.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4rhg-h8f2-v4jm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4rhg-h8f2-v4jm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-7818

Advisory: pgAdmin 4 has deserialization of untrusted data in its FileBackedSessionManager
IDs: CVE-2026-7818, GHSA-4rhg-h8f2-v4jm
Record: https://patchnext.com/advisories/cve-2026-7818 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pgadmin4 9.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pgadmin4: affected < 9.15; fixed in 9.15

## Suggested inspection (read-only)
- `python -m pip show pgadmin4`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pgadmin4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4rhg-h8f2-v4jm (OSV record GHSA-4rhg-h8f2-v4jm lists affected ranges: PyPI pgadmin4 >=0 <9.15 (fixed))
- Verified: https://github.com/advisories/GHSA-4rhg-h8f2-v4jm (GitHub-reviewed advisory GHSA-4rhg-h8f2-v4jm lists affected ranges: PyPI pgadmin4 >=0 <9.15)

Commands are suggestions: review each one before running it.

Loading voting…