Multiple security fixes in justhtml
CVE-2026-7808GHSA-4p64-v8f5-r2gx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI justhtml
- Affected
- <= 1.15.0
- Fixed in
- 1.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4p64-v8f5-r2gx lists affected ranges: PyPI justhtml >=0 <1.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4p64-v8f5-r2gx lists affected ranges: PyPI justhtml >=0 <=1.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2026-7808: 0.59% estimated exploitation activity in the next 30 days; percentile 48.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary justhtml 1.16.0 fixes multiple security issues in sanitization, serialization, and programmatic DOM handling. Most of these issues affected one of these advanced paths rather than ordinary parsed HTML with the default safe settings: - programmatic DOM input to sanitize() or sanitizedom() - reused or mutated sanitization policy objects - custom policies that preserve foreign namespaces such as SVG or MathML Affected versions - justhtml <= 1.15.0 Fixed version - justhtml 1.16.0 released on April 12, 2026 Impact Policy reuse and mutation Nested mutation of sanitization policy internals could weaken later sanitization by leaving stale compiled sanitizers active, or by mutating exported default policy internals process-wide. In-memory sanitization gaps Programmatic DOM sanitization could miss dangerous mixed-case tag names such as ScRiPt or StYlE, and custom dropcontenttags values such as {"SCRIPT"} could silently fail to drop dangerous subtrees. Serialization injection Crafted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4p64-v8f5-r2gx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4p64-v8f5-r2gx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7808 Advisory: Multiple security fixes in justhtml IDs: CVE-2026-7808, GHSA-4p64-v8f5-r2gx Record: https://patchnext.com/advisories/cve-2026-7808 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: justhtml 1.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI justhtml: affected <= 1.15.0; fixed in 1.16.0 ## Suggested inspection (read-only) - `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on justhtml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4p64-v8f5-r2gx (OSV record GHSA-4p64-v8f5-r2gx lists affected ranges: PyPI justhtml >=0 <1.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4p64-v8f5-r2gx (GitHub-reviewed advisory GHSA-4p64-v8f5-r2gx lists affected ranges: PyPI justhtml >=0 <=1.15.0) Commands are suggestions: review each one before running it.
Loading voting…